GL1800Riders Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Any info on the entire radio panel on an 08 GL1800 going inoperative? I've checked all fuses including to 40A at the bottom of the fuse panel. Everything else works fine. It worked fine, then I installed additional strobe lights to the brake lights (a simple splice off of the green/red brake wire at the bulb holder). I did have the seat off looking for the brake wire with a volt/ohm meter ... unplugged a couple of multi wire connectors and replugged them. I have rechecked the connectors and they all went back together with little effort and clicked into place. It seems that the Radio panel is dead. The LCD screen shows Info like temp, but not the icon for headset/speaker when that selection/button is pushed.
Is there a single power source for the radio/audio panel? any Ideas before it goes to the shop?
Curtis Speaker
'08 GL1800 / RoadSmith Trike
 

·
Registered
Joined
·
2,888 Posts
A friend of mine lost his radio panel and after a lot of searching the mechanic disconnected his passenger push to talk switch and it started working again. He put on a new passenger push to talk and no problems since. I know it sounds dumb but that's what happened.
 

·
Registered
Joined
·
1,100 Posts
Try resetting the radio. Pull fuses 20 & 21 and any MP3 device on the CD player connection. Give it about 5 minutes without power. Sometimes I'll pull the brake lever and press a few radio buttons to ground out stray charge to help zero it. Put the fuses back in and start the bike, turn on the radio and test functions. If good set you stations and clock again!
 

·
Registered
Joined
·
8,095 Posts
Blow some compressed air around all the radio buttons while trying to work them, even a small grain of sand will jam them up and the radio won't work.
 

·
GL1800 Doctor
Joined
·
20,203 Posts
Any info on the entire radio panel on an 08 GL1800 going inoperative? I've checked all fuses including to 40A at the bottom of the fuse panel. Everything else works fine. It worked fine, then I installed additional strobe lights to the brake lights (a simple splice off of the green/red brake wire at the bulb holder). I did have the seat off looking for the brake wire with a volt/ohm meter ... unplugged a couple of multi wire connectors and replugged them. I have rechecked the connectors and they all went back together with little effort and clicked into place. It seems that the Radio panel is dead. The LCD screen shows Info like temp, but not the icon for headset/speaker when that selection/button is pushed.
Is there a single power source for the radio/audio panel? any Ideas before it goes to the shop?
Curtis Speaker
'08 GL1800 / RoadSmith Trike
Pull fuses 25 and 31, wait 10 minutes and reinstall them and try it again. The other fuses mentioned are for the 01-05 model years, not yours.

 

·
Registered
Joined
·
369 Posts
A friend of mine lost his radio panel and after a lot of searching the mechanic disconnected his passenger push to talk switch and it started working again. He put on a new passenger push to talk and no problems since. I know it sounds dumb but that's what happened.
Thanks dwatc,
My friends radio was acting the same way and we followed your post and all is well again, we did not reconnect the push to talk, will be sending it back to J&M for repair or replacement..

Thanks again,
Joe W.
 
1 - 8 of 8 Posts
Top