GL1800Riders Forums banner

1 - 13 of 13 Posts

·
GL1800Riders Founder
Joined
·
1,813 Posts
Discussion Starter #1
:shock: This unit is working fine except for one thing. If I let set and am not moving for any amount of time I lose satalite and have to power off and back on again to get it to work. :roll: Looks like I'll be calling again today. :cry:
 

·
Registered
Joined
·
1,550 Posts
I'm curious, what kind of response do you get when you call? By now you must be a pretty familiar voice to them. They must be pretty apologetic, I would think they would be just about ready to give up.

Also....

How's the Boss Hoss project coming?
 

·
Registered
Joined
·
12,417 Posts
Lamont,

Take that thing down to the dog shelter, swap it in on a dog. Then go home and shoot the dog.

That should take care of your problems...LOL

Bulldog
 

·
Registered
Joined
·
2,272 Posts
Bulldog said:
Lamont,

Take that thing down to the dog shelter, swap it in on a dog. Then go home and shoot the dog.

That should take care of your problems...LOL

Bulldog
From all the troubles he has had with those units, they are not even worth swapping for a dog......... They are why man created junk yards.........
 

·
Squating Member
Joined
·
7,056 Posts
You're sure a lot better than me. I'd be sending it back for good a long time ago....but I guess that's way you can put up with us on the board :lol:

You Da Man
 

·
Registered
Joined
·
6,891 Posts
Goldwing_Midland_TX said:
...Let us know the results. I had the same thing happen twice over the weekend. I was stopped in full view of the sky for maybe 10 minutes. Went to get on and take off, and would never lock on. Turned it off, and right back on and immediately locked on again.
This happened to me a couple of times on the CA trip, but I assumed it was because I left the unit on under my coat while we were stopped for lunch and it was DAMN HOT. It only happened after upgrading to Ver. 1.7.

If you're having trouble with issues like this, we all need to call Lowrance (800-324-1356) and let them know. If they don't know about the problem, they can't fix it.

Garmin had the same problem when they upgraded the firmware in the 2720 from Ver. 2.70 to Ver. 2.80 - as soon as everyone let them know about the satellite lock issue, they fixed it in 2.90.

When I called them, they gave the standard answer: "we've never heard of or seen this problem ourselves". If we don't let them know that it's more than just an isolated problem, it's our fault if it doesn't get fixed. (No matter who the manufacturer is - it's just like the screen hazing problem on the 376 - Garmin needs to know it's more than just one unit failing)
 

·
GL1800Riders Founder
Joined
·
1,813 Posts
Discussion Starter #8
My was not related to heat as far as I could tell. It would lock back on right away after powering off and back on again. I think I must be the most unlucky iway owner in the world.
 

·
Registered
Joined
·
6,891 Posts
I'm not saying mine was related to heat - that was just my assumption... I know that I didn't have an overheat warning message when I lost the lock, but it returned immediately after a power cycle, which leads me to believe that it's related to the firmware and not something physical in the unit.

They had some issues reported like this with the 350's 'standby power mode' - I wonder if when they imported some of the functionality of the 350 into the 500, if they imported a bug as well?

You ARE the most unlucky user, that's for sure.
 

·
Registered
Joined
·
4,157 Posts
Just out of curiosity, have you tried to get your money back?

My third edition is working OK, but can't be left on the dash of the car. As long as it's on the bike it's OK.
 

·
GL1800Riders Founder
Joined
·
1,813 Posts
Discussion Starter #11
Rastoff said:
Just out of curiosity, have you tried to get your money back?

My third edition is working OK, but can't be left on the dash of the car. As long as it's on the bike it's OK.
They offered to give me my money back on number 6 or 7 but I just want a good working unit like some of you have. :roll:
 

·
Registered
Joined
·
2,272 Posts
If you want a good working unit, maybe you should try some other maker cause Lowrance seems to suck big time for you. You must have a ton of patience, cause I would have dumped Lowrance after the 2nd bad unit....
 

·
Registered
Joined
·
6,006 Posts
I seem to recall someone else posting of this same problem within the last month and as I recall a couple others responded affirming that they had had the same thing happen to them.
 
1 - 13 of 13 Posts
Top