GL1800Riders Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
So I drove to work today after a long winter as it was 80 degrees this afternoon. At lunch, I went to the park to take a walk. When I got ready to leave, my trike wouldn't start. Humm. I know it was a long winter but surely I didn't forget how to start this thing. So here is what I know......

Bike was shut off in 1st gear.
When trying to start, key on, I just pulled in the clutch, hit starter, nothing.
Put the bike in neutral, green light on, hit the starter, nothing.
Scratch head, checked kill switch, flipped switch, hit reverse switch, hit the starter, nothing.
Starting to panic now, who to call, embarrassed to get my truck and trailer to haul it home. Guys at work won't let me live this down.

I will say, each time I hit the start button, I could hear a relay click on the left side down by my leg. Heard this every time. Never turned over.

Finally hit the start button one more time, started right up.
Drove back to work. Tried every thing I just did at the park. Started every time.
Drove it home this evening, went through all the same scenarios, started every time.

2012, 8K miles, always garaged.

Don't think it's the battery. When it did start, it started just like the day I got it.
Don't believe it was anything with the clutch switch, it should of started in neutral.
Maybe bad battery connection??? I'll check....
I'm leaning towards the kick stand switch, but don't know.

Any ideas? Thoughts?
 

·
Registered
Joined
·
20,954 Posts
check to make sure the battery cables are tight, 10mm socket works great
 

·
Registered
Joined
·
33 Posts
Discussion Starter #4
Thanks guys. I googled starter relays and found another thread where the nut was cross threaded. The symptoms described in that thread sounds exactly what happened today. I have to travel for the next several days but when I return next week that side cover is coming off to see what I can find.
 
1 - 4 of 4 Posts
Top