GL1800Riders Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
I have this interesting problem with my 2013 Wing. The other day my horn goes off while the Wing is parked in the garage, it had not been disturbed. I was finally able to turn the horn off by pulling the “15A Battery” fuse. Everything appeared to work except the display screen (GPS) and the horn still worked by pressing the horn button. I put the fuse back in and the Wing set in the garage for another two days with no problems. When I moved the Wing yesterday to put it on its center stand the horn went off again? So I pulled the same fuse. I disconnected the battery hoping that by doing so it may reset the system, no luck. If I insert the fuse the horn stays on? Has anyone had this problem? Thanks for any help.
 

·
IronMan
Joined
·
17,461 Posts
maybe neighbors garage opener on same frequence ? maybe its got a ghost that wants to ride instead of sittin :shrug:;)
 

·
Registered
Joined
·
7,379 Posts
Sounds like the key fob horn/alarm function is getting activated for some reason. As it is under warranty, take it in and let the dealer a) troubleshoot it, and b) replace the receiver module.

Do make sure the key fob isn't in some position that is activating the function, or has a jammed/stuck button on it first.
 

·
GL1800 Doctor
Joined
·
20,205 Posts
Sounds like the key fob horn/alarm function is getting activated for some reason. As it is under warranty, take it in and let the dealer a) troubleshoot it, and b) replace the receiver module.

Do make sure the key fob isn't in some position that is activating the function, or has a jammed/stuck button on it first.
:agree: the trunk lock control unit is probably malfunctioning.
 
1 - 6 of 6 Posts
Top