GL1800Riders Forums banner
1 - 2 of 2 Posts

·
Registered
2018 Honda Gold Wing
Joined
·
8,970 Posts
jfrazsr said:
I had noticed some moisture under the screen months ago,but it would burn off kind of like your wrist watch does if it gets a little damp.I thought these units were water proof but I guess not.One good thing it happened all at once and before the warranty was up.Has anyone else seen this trace amount of moisture on their screen or had it to wrinkle up?John
I have noticed from time to time some moisture in the center and under the screen, always in the same spot. It always clears up while riding. When I first saw it I was riding for a week in the rain and I fiqured it was because of that, but I have also seen it come back when it hasn't gotten wet, like on a cloudy day when it looks like it's going to rain. The spot has always went away when the sun shines on the screen for a while. I always use the Garmin screen cover on the 2610 when the bike is parked and I have even started to take the 2610 in the house instead of leaving it on the bike in the garage but it has made no difference. My 2610 works just fine and the screen coating looks fine, it's just annoying me that this unit is supposed to be waterproof and I'm getting this moisture spot under the screen. I wonder how the moisture is getting inside the unit.
 

·
Registered
2018 Honda Gold Wing
Joined
·
8,970 Posts
I have still been having moisture under the screen with my 2610. The moisture under the screen will come and go when the unit gets warm, so the moisture has got to be trapped inside the unit. BTW, my friend is having the same problem with his 2730.

I then thought of opening the compartment door where the CF card goes in the unit and riding around with the power on to heat the unit up to see if the moisture would get out of the unit through the CF compartment opening. I also let it sit in the sun with the power on and with the CF compartment door open. The moisture has seemed to have vented out of my unit now and the screen looks great now.

I just thought I would mention that so if anyone else is having the same problem.
 
1 - 2 of 2 Posts
Top