GL1800Riders Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter #1
I have a Kwik Kamp Trailer with a 5 wire system, had the trailer checked and all lights are working properly, Installed the Add on plug and play 5 Wire, all worked well, until I tested the brake (Blew the 10 amp Fuse) has anyone had this issue,if so I would appreciate a solution.

Thank
Bob
 

·
Registered
Joined
·
33 Posts
Well....I just put the plug and play harness on for my trailer and every time I plug in the 3 wire red connector...I blow the 20 amp fuse for the tail lights and dash gauges....Still trying to figure it out...:eek:4:
 

·
Registered
Joined
·
120 Posts
My dad's trike does this when he plugs it in backwards. He rotates the plug and all is good
 

·
Banned
Joined
·
11,396 Posts
I have the same brand and everything runs fine.
Something somewhere is shorted to ground in order to blow a fuse.
You'll have to disconnect each light wire to detect which circut is causing it.If everything on the bike works fine without the trailer plugged in,then you got a pinched wire somewhere on the trailer.
 

·
Registered
Joined
·
528 Posts
I have the same brand and everything runs fine.
Something somewhere is shorted to ground in order to blow a fuse.
You'll have to disconnect each light wire to detect which circut is causing it.If everything on the bike works fine without the trailer plugged in,then you got a pinched wire somewhere on the trailer.
:agree:

You have something wired incorrectly. I have the same brand and it works fine.
 

·
Registered
Joined
·
33 Posts
I was blowing tail light fuses and didn't even have the trailer hooked up... and the red plug has the orange wire for left turn signal but blows tail light fuse...strange....But Add on Acc. is sending me a new plug at no charge without the extra relays for the abs brakes. Wing Stuff, who I bought it from, was no help.
 

·
Banned
Joined
·
11,396 Posts
I was blowing tail light fuses and didn't even have the trailer hooked up... and the red plug has the orange wire for left turn signal but blows tail light fuse...strange....But Add on Acc. is sending me a new plug at no charge without the extra relays for the abs brakes. Wing Stuff, who I bought it from, was no help.

That Sukz about WING STUFF being no help.They helped take your money though.:wrong:

You know until you mentioned what Add On was going to do for you,I had completely forgotten that a long time ago a few guys had a bad trailer isolation harness.I can't remember what the brand was.But it doesn't matter.Things fail.
But I haven't heard of a failed isolation harness in a ***** age.:shrug:

What matters is Customer support after the purchase.Kudo's to Add On for standing behind their product.:bow:
 
1 - 8 of 8 Posts
Top