GL1800Riders Forums banner
1 - 15 of 15 Posts

·
Registered
Joined
·
1,244 Posts
Save your money and mount LED's above the controls or do something else. I put those cheap things on my '02 back in '03 and they started going dark from the edges within the 1st 6 months. Now they are useless. Someone else already mentioned the cheesey connectors so I won't say anything else about them.
 

·
Registered
2018 Honda Gold Wing
Joined
·
8,823 Posts
MotorcycleBoy said:
Save your money and mount LED's above the controls or do something else. I put those cheap things on my '02 back in '03 and they started going dark from the edges within the 1st 6 months. Now they are useless. Someone else already mentioned the cheesey connectors so I won't say anything else about them.
Why didn't you contact Rivco when you noticed they weren't working correctly in only 6 months? They most likely would have replaced them for you.

I really like my Rivco lighted controls. They were one of the first items I added to my 03. They look like they are factory items on the bike and I think they look better than the lighted controls that Honda puts on the 04 and up model Wing. I have had my Rivco lighted controls for over 3 years now, have rode many miles in the rain, and they have worked flawlessly and still look brand new. I do turn them off in the day time as I do with all my added lights.

The only down side to the Rivco lighted controls is if you have to remove the control pods for any reason then the Rivco units might be damaged and need to be replaced. I email Rivco about this and they said to use a hair dryer to heat them up and they would come off and to reinstall them using some adhesive. I also thought I seen that Rivco was selling replacement panels, I think one side at a time in case there is a need to replace them.
 

·
Registered
Joined
·
400 Posts
I have them on my O3 and are great at night. They seem to a little fragile and the double back tape doesn't last long. Now have to find a way to stick it back down.
 

·
Registered
Joined
·
180 Posts
Had enough fumbling in the dark.
Ordered the lights last week, they arrived so quick via USPS, Started to fit, realized there were no connectors on one of the lamps. looks like the packaging process chopped them off.
Contacted Cyclemax, they were very helpful New lamp arrived today direct from Rivco.
So nice to get that kind of service from vendors.
Jas
 

·
Registered
Joined
·
337 Posts
I put them on my '01 after taking a long trip and coming back in the dark and fumbling around for the right button (thought I had them memorized too) and I really like them. I usually keep them dimmed unless it's getting dark out.

An installation tip, when you bend the them around the switch housings carefully use a hair dryer to WARM them and they will conform to the shape better. After they are bent keep working them until they cool and they will stay tight.
 
1 - 15 of 15 Posts
Top