GL1800Riders Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
361 Posts
Discussion Starter #1
Just installed a new air filter and now it want start or turn over. any ideas?
 

·
Registered
Joined
·
361 Posts
Discussion Starter #3
Started when I moved it before, looking at the connections the only ones I remember unhooking was the cruise control, one of the 4 on the piece above the air filter and the one but the ignition switch all plugged in. kill switch is in the correct position does the seat have tho be installed for it to start?
 

·
Registered
Joined
·
8 Posts
You also have to unhook all the plugins located in front of the front center console at the bottom, if you plugged them all back in, check and see if you unplugged the ecm.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
2,780 Posts
You also have to unhook all the plugins located in front of the front center console at the bottom, if you plugged them all back in, check and see if you unplugged the ecm.


Sent from my iPad using Tapatalk

I don't see the need to remove the plugs you are talking about. I just changed the filter in my 2012, and the only plug I removed was the one on the airbox cover.
 

·
Registered
Joined
·
361 Posts
Discussion Starter #8
Took it apart and could not find anything put back together and it started, thanks for all your comments.
 

·
Registered
Joined
·
711 Posts
Just installed a new air filter and now it want start or turn over. any ideas?
Did you bump it into gear, or leave it in gear when you last moved it?
 

·
Registered
Joined
·
361 Posts
Discussion Starter #10
Nope checked all that must have been a fluke but after doing this 2-1/2 times today i'm getting pretty good at it lol.
 

·
Registered
Joined
·
143 Posts
Wish you had posted pics of the tear down! I need to get at mine but feeling very intimidated.
 

·
Registered
Joined
·
50 Posts
Wish you had posted pics of the tear down! I need to get at mine but feeling very intimidated.


Layne, I just did mine about a week ago. This Partzilla video is the one I used. Went super smooth. I was totally intimidated too. I didn't want to mess up or end up putting it back together and having it NOT START. That would have freaked me out. Anyway, this video was great.

 

·
Registered
Joined
·
5,968 Posts
WOW! This was without a doubt the best video ever on how to replace that Ugggggg filter........Thank you!

Ronnie
 

·
Registered
Joined
·
361 Posts
Discussion Starter #16
From my experience the 1st time is the worst but once you do it not that bad so when I had to take everything off again was much easier. I had Fred's video and my service manual, just a bunch of stuff to take off.
 
1 - 16 of 16 Posts
Top