GL1800Riders Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
I have 2001 CSC trike with 148000 miles. I took left side panel under glovebox to try to get fog lights working. Couldn’t get them working so I buttoned it up. That and looked at fuse panel for a fuse and didn’t see one. Jumped on it to go for ride and looked down and instrument panel was completely down. No tach,speedo,temp and gas gauge. I didn’t see a fuse just for that. All lights,audio,reverse,and cruise was fine. This has me completely stumped. I haven’t taken seat off yet. Trike has been doing so well before this. I don’t know where to start next. Any help would be greatly appreciated. Tks in advance. Bruce
 

·
Registered
Joined
·
56 Posts
General rule is revisit the last area you worked on. Double check any connectors you disturbed or put you hands on or bumped.
 
  • Like
Reactions: turboman1354

·
Registered
Joined
·
38 Posts
Discussion Starter #3
I went ahead and pulled seat to look at C5 connector. I also checked everything I did yesterday and still don’t see anything out of ordinary. Pull service manual up and looked at wiring diagram for meter panel. I’m pretty well flustered by this. Hope somebody can help me here.
Tks in advance. Bruce
 

·
Registered
Joined
·
337 Posts
Before you start pulling out your hair, try disconnecting the battery for about ten minutes. There is still plenty of time to panic.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #5
Electrical problem

Tks Audi I tried battery reset and still no gauges. I’m tempted to put back together and drive it using speedo and odometer app on phone. I hope techdude will chime in with solution. He’s a whiz on electrical stuff. Tks again all. God Bless.
Bruce
 

·
Registered
Joined
·
1,665 Posts
I'd check all the fuses with a test light.


Then locate whatever Relay's might control the gages mentioned... Swap the one/s for the affected circuit with another same-size from elsewhere.


Then, I'd follow the wires from the gages mentioned, seeing if they are all connected to a Common Connectors... to verify that the connector is clean/working.
 
  • Like
Reactions: turboman1354

·
Registered
Joined
·
56 Posts
Tail Light fuse for the dash. Gonna have to remember that one.
 

·
Registered
Joined
·
56 Posts
Like the Reserve Lighting Unit on the early models. Makes sense.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #12
I should’ve remembered from past experience. I’ll be 65 in a couple of months. I think I’m going senile in my old age. My own stupidity amazes me sometimes. Spent a whole day worrying over something so simple. If it wasn’t for this forum I’d probably lose my mind. LOL
Tks all and God Bless
Bruce
 
1 - 12 of 12 Posts
Top