GL1800Riders Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
273 Posts
Discussion Starter #1
A few months ago Apple Car Play was disconnecting randomly, once every 4 hours or so of connect time. The fix – disconnect and reconnect my Iphone. So I bought an installed the USB Cable with the On/Off Inline Rocker Switch that others recommended, so that I could simply turn the switch on/off when driving if car play disconnected. The cable: https://www.amazon.com/gp/product/B07QTJZD99/ref=ppx_od_dt_b_asin_title_s00?ie=UTF8&psc=1
So after installing the cable I rode for a couple of months and car play never disconnected again. Until today. After lunch and driving about 20 minutes, it disconnected. While driving, turned the switch on/off and car play fired right back up. This happened 2 more times within a 5 minute interval. I gave up, and a few minutes later when I arrived home I took my phone out of the front cubby and checked it for overheating. It was not hot at all. I also checked all the connections from the bike’s USB connector through both cables to the phone. All were snug and secure.

I am clueless. Don’t know if it is the phone, or the bike. Anyone know what causes apple car play to randomly disconnect?
 

·
Registered
Joined
·
286 Posts
Yes mine does that. I have the switch also. unhooked from switch and still does it. Used apple cord and still does it. I wish i had answer for ya.
 

·
Registered
Joined
·
577 Posts
Sorry. No can help. Ran 6+ hours today with ACP running Waze (for the obvious reasons) and never once disconnected. Some months back, I did a complete reset and rebuild of the bike's system and my iPhone. Once I got everything back up and running, I've had no problems - knock on wood. Even through a couple of iPhone updates and from the last released bike software update. Doing the reset and rebuild was a somewhat involved process and not for the faint of heart. But, like most things, it a'int rocket science (I used to do rocket science for living before retiring and discovering there is life outside of work).
 

·
Registered
Joined
·
369 Posts
I have found mine does this if I have more than one GPS app running at a time, example Waze and Apple Maps. They are fighting over the GPS signal and crash the phone.

Just my two cents


Sent from my iPhone using Tapatalk
 
  • Like
Reactions: jdukes52

·
Registered
Joined
·
132 Posts
A few months ago Apple Car Play was disconnecting randomly, once every 4 hours or so of connect time. The fix – disconnect and reconnect my Iphone. So I bought an installed the USB Cable with the On/Off Inline Rocker Switch that others recommended, so that I could simply turn the switch on/off when driving if car play disconnected. The cable: https://www.amazon.com/gp/product/B07QTJZD99/ref=ppx_od_dt_b_asin_title_s00?ie=UTF8&psc=1
So after installing the cable I rode for a couple of months and car play never disconnected again. Until today. After lunch and driving about 20 minutes, it disconnected. While driving, turned the switch on/off and car play fired right back up. This happened 2 more times within a 5 minute interval. I gave up, and a few minutes later when I arrived home I took my phone out of the front cubby and checked it for overheating. It was not hot at all. I also checked all the connections from the bike’s USB connector through both cables to the phone. All were snug and secure.

I am clueless. Don’t know if it is the phone, or the bike. Anyone know what causes apple car play to randomly disconnect?
Just a thought but my experience is that the lightning connector on the iphone is very prone to connection problems caused by lint or dirt in the jack on the iPhone. I normally have to clean the lint out with toothpick or whatever - plenty of tips on the internet about this. I have had cases where I have to re-seat the lightning port connection several times just to get it to charge, or to have it charging and then quit charging after slightly bumping the phone. I'm sure the vibrations on the bike can make this worse.

So I would start there - I too sometimes have the carplay connection problems, and they clear up when I clean the port.
 

·
Registered
Joined
·
1,159 Posts
The only time my Carplay disconnects is when my helmet Bluetooth dies.
 

·
Registered
Joined
·
478 Posts
I too sometimes have the carplay connection problems, and they clear up when I clean the port.
This.

First thing to check is always the cable. Vibrations and movement from motorcycle use are extremely hard on cables, always check first with a known good cable. It wouldn't surprise me if the mechanical switch is failing.
I buy actual Apple cables for motorcycle use. They are the most durable.

Next, clean the port. Gentle toothpick, or careful use of compressed air. It only takes a speck of lint to make things act up.

If there's still a problem, gently use compressed air on the USB port on the bike. Again, a speck of dirt/lint in the wrong place can cause problems.
 

·
Registered
Joined
·
273 Posts
Discussion Starter #8
A few months ago Apple Car Play was disconnecting randomly, once every 4 hours or so of connect time. The fix – disconnect and reconnect my Iphone. So I bought an installed the USB Cable with the On/Off Inline Rocker Switch that others recommended, so that I could simply turn the switch on/off when driving if car play disconnected. The cable: https://www.amazon.com/gp/product/B07QTJZD99/ref=ppx_od_dt_b_asin_title_s00?ie=UTF8&psc=1
So after installing the cable I rode for a couple of months and car play never disconnected again. Until today. After lunch and driving about 20 minutes, it disconnected. While driving, turned the switch on/off and car play fired right back up. This happened 2 more times within a 5 minute interval. I gave up, and a few minutes later when I arrived home I took my phone out of the front cubby and checked it for overheating. It was not hot at all. I also checked all the connections from the bike’s USB connector through both cables to the phone. All were snug and secure.

I am clueless. Don’t know if it is the phone, or the bike. Anyone know what causes apple car play to randomly disconnect?
Think I figured out why Apple Car Play was disconnecting. I had been forgetting to turn Bluetooth Off in my Iphone settings. ACP would connect and work with Iphone Bluetooth on, but would not stay connected.

For my last 3-4 outings on bike, I turned Iphone bluetooth off and ACP never disconnected. Time will tell if Iphone bluetooth on was the culprit, but I am 95% sure that's it.
 

·
Registered
Joined
·
130 Posts
It’s OK to leave the phone Bluetooth on - just don’t pair your phone to the bike or your headset.

Pair your headset to the bike.

Leave the phone unpaired.




Sent from my iPhone using Tapatalk Pro
 

·
Registered
Joined
·
1,746 Posts
using the correct cable and no bluetooth connection between the bike and phone. those need to be checked first every time. theyre the biggest and most frustrating culprits in the equation.
 

·
Registered
Joined
·
273 Posts
Discussion Starter #11
It’s OK to leave the phone Bluetooth on - just don’t pair your phone to the bike or your headset.

Pair your headset to the bike.

Leave the phone unpaired.




Sent from my iPhone using Tapatalk Pro
My headset is paired to bike.
I just turned off (setting on bike) phone pairing. Before I had started using car play, had phone paired direct to bike.

So now I should be able to leave phone Bluetooth on without interfering with car play?
 

·
Registered
Joined
·
273 Posts
Discussion Starter #12
using the correct cable and no bluetooth connection between the bike and phone. those need to be checked first every time. theyre the biggest and most frustrating culprits in the equation.
Yes - bluetooth connection between bike and phone appeared to be my culprit! I just turned off (bike setting) phone pairing, so should be able to leave bluetooth on (phone setting) which I need when not riding the bike.
 
  • Like
Reactions: Drgsin

·
Registered
Joined
·
273 Posts
Discussion Starter #13
A few months ago Apple Car Play was disconnecting randomly, once every 4 hours or so of connect time. The fix – disconnect and reconnect my Iphone. So I bought an installed the USB Cable with the On/Off Inline Rocker Switch that others recommended, so that I could simply turn the switch on/off when driving if car play disconnected. The cable: https://www.amazon.com/gp/product/B07QTJZD99/ref=ppx_od_dt_b_asin_title_s00?ie=UTF8&psc=1
So after installing the cable I rode for a couple of months and car play never disconnected again. Until today. After lunch and driving about 20 minutes, it disconnected. While driving, turned the switch on/off and car play fired right back up. This happened 2 more times within a 5 minute interval. I gave up, and a few minutes later when I arrived home I took my phone out of the front cubby and checked it for overheating. It was not hot at all. I also checked all the connections from the bike’s USB connector through both cables to the phone. All were snug and secure.

I am clueless. Don’t know if it is the phone, or the bike. Anyone know what causes apple car play to randomly disconnect?
FINALLY (99% sure) isolated the problem. After unpairing my phone from the bike, I thought problem was solved. But after a few outings car play starting randomly disconnecting again. And then it would not reconnect when I turned the switch on/off. Today when riding it dawned on me that I probably had a bad lightning cable. So when I got home I played with the cable by gently bending it and sure enough found that it had a weak spot where the slightest movement (bending) made car play disconnect. Replaced the cable and could not (by moving / bending the cable) make car play disconnect. Am taking couple long rides this weekend that will solidify my theory, but pretty sure it was a bad cable that, due to bike vibrations, would move and cause car play to disconnect.

So what I have learned from this thread: If you are having problems with car play disconnecting, do the following:
  1. Make sure your phone IS NOT paired to your bike or headset
  2. Clean your connections (lightning cable to bike, and to phone)
  3. If in doubt, buy a new quality lightning cable
 
  • Like
Reactions: Drgsin

·
Registered
Joined
·
4,428 Posts
I am wondering if I can pair a Garmin and Carplay, both, to my Sena20. Then, would I be able to hear alerts from Waze on Carplay, while I hear directions from Mr GarminVI at the same time--without one or the other disconnecting???????
 
1 - 14 of 14 Posts
Top