GL1800Riders Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
I’m having an intermittent problem with the audio on my 2013 GW trike. Occasionally, the audio will cut out whenever the bike is in gear. If I squeeze the clutch handle it comes back on. As soon as I release the clutch it goes off. If the bike is in neutral, the audio is on no matter which way the clutch handle is. This happens with both radio and aux. Sometimes everything works as it should. Has anyone else experienced this? Any ideas?
 

·
Registered
Joined
·
9,328 Posts
Are you inadvertently hitting the mute button when it stops working?
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
Are you inadvertently hitting the mute button when it stops working?
Ha! No, but thanks for asking ?. In fact, the “MUTE” icon doesn’t appear on the screen when this happens. It appears to be completely cutting off the audio.
 

·
Registered
Joined
·
1,068 Posts
One thing, check all the ground connections. Check your start switch. After that I'm not sure what else.
 

·
GL1800 Doctor
Joined
·
20,363 Posts
I’m having an intermittent problem with the audio on my 2013 GW trike. Occasionally, the audio will cut out whenever the bike is in gear. If I squeeze the clutch handle it comes back on. As soon as I release the clutch it goes off. If the bike is in neutral, the audio is on no matter which way the clutch handle is. This happens with both radio and aux. Sometimes everything works as it should. Has anyone else experienced this? Any ideas?
Is this a CSC trike? If so, you should have a white wire that is ground for the trike kit, make sure it’s connected to the battery’s negative post and not the positive post.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #6
This sounds like possibly pinched wires in the left handlebar. I would drop the handlebar cover off and check for wires being pinched near the screw holes.
I thought of that possibility but it doesn’t happen in neutral. In neutral I can squeeze the clutch all day long with no problem. It only happens when in gear...and not all the time at that.
 

·
GL1800 Doctor
Joined
·
20,363 Posts
I thought of that possibility but it doesn’t happen in neutral. In neutral I can squeeze the clutch all day long with no problem. It only happens when in gear...and not all the time at that.
Yea, missed that at first, checkout my post #5 above.
 
1 - 7 of 7 Posts
Top