GL1800Riders Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Lights on left side rear not working,
I have not replaced them. I'm curious, "why" would you want to replace them.


it seems you have to take off plastic on rear of saddle bag, center plastic license plate, plus plastic piece with emergency key area and all plastic around top bag,just to get at light assembly to replace LEDs. Just wondering if anyone attempted this?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Don't know what happened there,sorry .rear break light and blinker not working. Looking at it it seems the plastic on back of saddle bag and plastic for license plate assembly plus plastic for emergency key area and all plastic around top bag. Just to get to the light assembly, to replace LEDs. Seems like a lot to take off just to replace blown LEDs. Looking for advice. Thank you
 

·
Registered
Joined
·
352 Posts
Take the bike to the dealer for warranty repair.
BTW As far as I know you need to replace the entire assembly ($245?)
 

·
Premium Member
Joined
·
443 Posts
I have replaced the right side brake / turn signal combo. There is a lot of plastic to remove but just take your time it is not hard. mine needed to be replaced because I had a wire from an add on turn signal rub against the tire. Be careful when adding accessories. If it is not something that you did take it to your dealer.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
I took off accessories plug on left side of bike,everything worked again. So I tried to put accessories plug back in and everything still worked? Took bike for a long ride and a lot of bumps, everything ok, maybe a bad connection and it loosened when riding? Everything good at this time. Thanks for suggestions for things to look for. Appreciate it
 

·
Registered
Joined
·
352 Posts
I took off accessories plug on left side of bike,everything worked again. So I tried to put accessories plug back in and everything still worked? Took bike for a long ride and a lot of bumps, everything ok, maybe a bad connection and it loosened when riding? Everything good at this time. Thanks for suggestions for things to look for. Appreciate it
Great! Thank you for let us know.
 
1 - 10 of 10 Posts
Top