GL1800Riders Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
136 Posts
Discussion Starter #1
i have a bushtec trailer and the onboard compressor has quite working , i have changed the battery in the remote and still does not work, took the top off the relay and closed it and the compressor came on and air up the trailer, took off the top other relay and closed it and aired down . check all the fuses and they are good . any help would be great.
 

·
Registered
Joined
·
2,189 Posts
have you ck'd the "black"/pos wire leading to the compressor?
also I had a problem w/ mine & replaced the remote unit in the trailer ordered it from Electrical Connection.com $50.
# 3- on my wing, the whole remote unit works best when the bike is "running" not just w/ the ingnition turned on, these have been my findings since I installed the remote compressor about 7 yrs ago.
 

·
Premium Member
Joined
·
1,627 Posts
Call EC

i have a bushtec trailer and the onboard compressor has quite working , i have changed the battery in the remote and still does not work, took the top off the relay and closed it and the compressor came on and air up the trailer, took off the top other relay and closed it and aired down . check all the fuses and they are good . any help would be great.
@gene1979 give Lewis a call @ Electrical Connection, he will get you squared away on any issues with the air compressor.
 
  • Like
Reactions: GLblinded

·
Registered
Joined
·
1,231 Posts
For those of you who have the Electrical Connection Trailer Air System, did you install it yourself or have it done at the factory? If you did it yourself, how difficult was the install? I checked out this system on Electrical Connection's website and the installation directions are not posted.
 

·
Registered
Joined
·
2,189 Posts
For those of you who have the Electrical Connection Trailer Air System, did you install it yourself or have it done at the factory? If you did it yourself, how difficult was the install? I checked out this system on Electrical Connection's website and the installation directions are not posted.
Installed the unit myself, not a bad job, black wire on trailer should be the aux power, white is the ground, cut in the air line & plug it all in & your set.
I did notice that the compressor works better when the bike is running, not just sitting there w/ the ignition turned on..
Give EC a call if you have any questions, they'll always help out..
BTW, I mounted compressor using 2 of the license plate bolts, the remote was installed by velcro on the back & attached to the carpet on rear of trailer.
 
  • Like
Reactions: Kenichi

·
Registered
Joined
·
2,189 Posts
For those of you who have the Electrical Connection Trailer Air System, did you install it yourself or have it done at the factory? If you did it yourself, how difficult was the install? I checked out this system on Electrical Connection's website and the installation directions are not posted.
Wingman, where do you live in NJ?
 

·
Registered
Joined
·
2,189 Posts

·
Registered
Joined
·
1,231 Posts
Just off Exit 3 of the Turnpike - Bellmawr
 
1 - 10 of 10 Posts
Top