GL1800Riders Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
273 Posts
Discussion Starter · #4 ·
I just spent 3 hours looking for that connector and could not find it. I guess I will take it to the dealer. If anyone has a picture of the connector that would be really cool.


Willy
 

·
Registered
Joined
·
94 Posts
I don't have a picture but I just installed mine on an 07 w/airbag. Remove the plastic on the right side and the connector is in the black boot on the left side of the air vent. Hope this helps.
James
 

·
Registered
Joined
·
273 Posts
Discussion Starter · #6 ·
Thanks for the help, but I think the 06 must be different from the 07. The connector is not in the little black boot or anywhere else I could find....

Willy
 

·
Registered
Joined
·
273 Posts
Discussion Starter · #8 ·
Yes, it is a US bike. I have been reading on the other board, where several people are having the same problem. Some have found it, but some like me haven't. The last I heard from Pete Hatfield is that the connector is located deep behind the black boot that in mentioned in the post above. I looked but still did not see it.

Willy
 

·
Chard Member
Joined
·
13,223 Posts
BillytheKidd said:
Yes, it is a US bike. I have been reading on the other board, where several people are having the same problem. Some have found it, but some like me haven't. The last I heard from Pete Hatfield is that the connector is located deep behind the black boot that in mentioned in the post above. I looked but still did not see it.

Willy
Pete and others on this board say it's on the right side in a large black boot. Keep digging and good luck. LOL... It should be large enough you couldn't miss it if you get close.
 

·
Registered
Joined
·
203 Posts
My CB plug was on the right side close to the radiator fill. I don't have an airbag model but the service manual shows it at the same place. Tried to paste the picture from manual but not figure it out. Richard
 
1 - 11 of 11 Posts
Top