GL1800Riders Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
Picked up an 2003 gl 1800 goldwing, read the manuel , says to press the mode button twice , and clock will blink . My clock wont blink ...any suggestion
 

·
Premium Member
Joined
·
1,630 Posts
Congrats on that 2003, same year I ride and could not be happier. If you turn on the ignition switch, push the mode button twice, the display will show clock adjust, mode, H, M. To adjust the hours, press the trip button and the hours on the clock will change. To adjust the minutes, press the display button and the minutes will change. Now, all that being said, when you press the mode button, does the display above the "mode, trip, and display" buttons light up and show Clock Adjust, or is it blank? If it's blank, look under the center cover, where the ignition switch is, there is a short (very short) pigtail which is connected to those buttons. If it's not plugged in or loose, the functions for those buttons won't work. Many times when someone works on something under the shelter, a wire gets pulled loose or the plug just doesn't get plugged in completely. I'd start my search there.

Also, Welcome from SE Idaho! :D
 

·
Registered
Joined
·
478 Posts
Picked up an 2003 gl 1800 goldwing, read the manuel , says to press the mode button twice , and clock will blink . My clock wont blink ...any suggestion
You say the "clock" doesn't blink. Are you looking at the clock or display? Once I had a senior moment and was thinking the display had to blink. I was pushing the trip button to change the hour and thought nothing was changing. Then notice the hour was changing on the clock.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #4
Congrats on that 2003, same year I ride and could not be happier. If you turn on the ignition switch, push the mode button twice, the display will show clock adjust, mode, H, M. To adjust the hours, press the trip button and the hours on the clock will change. To adjust the minutes, press the display button and the minutes will change. Now, all that being said, when you press the mode button, does the display above the "mode, trip, and display" buttons light up and show Clock Adjust, or is it blank? If it's blank, look under the center cover, where the ignition switch is, there is a short (very short) pigtail which is connected to those buttons. If it's not plugged in or loose, the functions for those buttons won't work. Many times when someone works on something under the shelter, a wire gets pulled loose or the plug just doesn't get plugged in completely. I'd start my search there.

Also, Welcome from SE Idaho! :D
Thank you ..ill look into it ...i started to pull that cover off , but then i said it getting late , and let me ask first . Ill keep ya posted ...thanks again
You say the "clock" doesn't blink. Are you looking at the clock or display? Once I had a senior moment and was thinking the display had to blink. I was pushing the trip button to change the hour and thought nothing was changing. Then notice the hour was changing on the clock.
I was looking at the clock ...no blink ...no response with the trip or display either ..weird ....but later today after work , ill pop off the ignition cover and see if the wire connection are on properly ....thanks for your reply ....keep ya posted
 

·
Premium Member
Joined
·
1,630 Posts
When you get ready to pull that center console off, the back just pulls loose from the rubber grommets. To get the front section loose, remove the speaker grills, they just pop off. In the bottom corner on each side is a cap screw. Remove those, and the only thing holding you up is the pigtail I mentioned. You'll understand the annoyance most folks have with that little delight when you get in there. Good luck, let us know what you find.
 
  • Like
Reactions: Ride with the wind

·
Registered
Joined
·
274 Posts
You can check that plug by seeing if you can check the temp or Display. Do you have an Owners manual with the bike.
 
1 - 7 of 7 Posts
Top