GL1800Riders Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
I smell antifreeze coolant after a ride and notice the loss of small amount of coolant loss. I have not been able to locate the leak. Probably a hose connection some place. Wondering if this would be covered by warranty?
03 GL1800A
 

·
Registered
Joined
·
150 Posts
pull the left side cover off, right in behind the shift lever is a hose and clamp (1 of 32 clamps!!), it's well known to leak, mine was, see if that stops ur smell/dribble.
Alan
 

·
Registered
Joined
·
16,865 Posts
I smell antifreeze coolant after a ride and notice the loss of small amount of coolant loss. I have not been able to locate the leak. Probably a hose connection some place. Wondering if this would be covered by warranty?
03 GL1800A
YES, if bike is in warranty.

prs
 

·
Registered
Joined
·
2,184 Posts
I'm tearing mine down tomorrow :eek:4: because I smell a moldy odor on the initial start up :22yikes:
assuming it's the infamous hose clamps :22yikes: gotta take the fuel tank of it, I dont' feel like taking it to the dealer, I would rather do the work myself..:excited::thumbup:
 

·
Registered
Joined
·
200 Posts
Like deerwing says, also there is a matching hose on the right side, I had to remove the lower cover to tighten the clamp, it was definately were my leak was, I also snugged the left one. depending on which way the clamps are facing will determine what cover to remove, for the left side I did not have to remove anything. the lower covers are a pita.
 

·
Registered
Joined
·
2,682 Posts
coolant leak

I just went thru the same thing. I had anti freeze on the floor right under the engine.
Checked the hoses that were easy to get to first.
I pulled the tank and found the leak at the 'Y' where both radiators connect. Honda had the screws on the clamps UNDER the hoses.
Two of the clamps were loose. Loosened all three and then spun them around until the clamp screws were on top.
About 2 1/2 hours work.
 

·
Registered
Joined
·
57 Posts
I just went thru the same thing. I had anti freeze on the floor right under the engine.
Checked the hoses that were easy to get to first.
I pulled the tank and found the leak at the 'Y' where both radiators connect. Honda had the screws on the clamps UNDER the hoses.
Two of the clamps were loose. Loosened all three and then spun them around until the clamp screws were on top.
About 2 1/2 hours work.
I'd be worried that the screws would rub on my fuel tank and cause it to leak. I think that's why they were installed upside down.
 
1 - 7 of 7 Posts
Top