GL1800Riders Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
Help! My cruise control button is stuck in the on position. It happened once before and I was able to work it around until it freed up. This time, nothing. Anybody else have this problem?

Jay
 

·
Registered
Joined
·
8,027 Posts
Mine has been like that from the day I got it, and I haven't even tried to unstick it. I use it too much to not have it to work when I need it. Don't hurt a thing. Leave it alone the nest time you want to use the cruse it will be there.
 

·
Registered
Joined
·
750 Posts
I had the same problem on my 02. I sprayed it heavily with some electronic parts spray cleaner and operated it a few times and that seems to have cured the problem. Place a heavy towel under the entire assembly so the cleaner won't run out on the right side pocket.
 

·
Registered
Joined
·
96 Posts
I not only have problems with my cruise control button sticking in the on position but I also have problems with the reverse button sticking. You can't go anywhere if he reverse button is stuck in the on position. I have a 02 with the Honda extended warrantee and 84,000 miles. I took it to my local Honda Dealer. They attempted to clean the switches without any luck so it’s there today getting a new switch cluster on that side. The left side was replaced about a year ago because the CB PPT only worked when it felt like it.
 

·
Registered
Joined
·
6 Posts
try using a good quality electrical spray which will clean the switch and then use a good switch lubricant such as Radio Shack tuner spray,,don't use WD-40,,,,,it's more of a solvent than lubricant,,not a good choice for electrical switches or lubricating anything critical,,,,I've even used a product called tri-flow which is a good teflon based lubricant and it won't get stiff or sticky even in real cold temps,,it has a good long lasting lubricating property,,,,,I've used this on all controls and switches,,,,,
 

·
Registered
Joined
·
496 Posts
I have a similar issue with the switch on the fog lights.....anybody else have this problem?
 
1 - 9 of 9 Posts
Top