GL1800Riders Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter #1
Gday

Might be getting my first wing this weekend. One of the reasons I'm getting a wing is the cruise control. Does it work well on the 06/
-09 years? Does it hold speed well? I'm assuming you have to turn it off prior to shifting gears?


Spiff
 

·
Registered
Joined
·
519 Posts
Gday

Might be getting my first wing this weekend. One of the reasons I'm getting a wing is the cruise control. Does it work well on the 06/
-09 years? Does it hold speed well? I'm assuming you have to turn it off prior to shifting gears?


Spiff
Mine has worked perfectly for almost 100,000 smiles. Some have to go in and adjust the cable but I've not had to even touch mine. As far as shifting, as soon as you start to pull in the clutch to change gears it de-activates the CC. The only difference feel to the Wing CC and the CC on any of my cages is when I touch resume when I'm running faster than it is set. Say I have it set at 65, touch the brake, speed up to 67 and then hit resume then my Wing will slow down to 62 or 63 and then the Wing picks back up to 65. I just try not to be running faster than I had it set when I hit resume or I use the throttle to ease back down to 65 and let the CC take over.:laugh: Hope this helps!
 

·
Registered
Joined
·
1,193 Posts
Pulling in the clutch lever will disengage the cruise control. So will using the front or rear brake.
So will returning the throttle to "idle".
I would never have a need to activate the cc until into fifth gear and steady speed.
 

·
Registered
Joined
·
237 Posts
The only difference feel to the Wing CC and the CC on any of my cages is when I touch resume when I'm running faster than it is set. Say I have it set at 65, touch the brake, speed up to 67 and then hit resume then my Wing will slow down to 62 or 63 and then the Wing picks back up to 65.
My 08 does the same. I've also noticed that sometimes CC will not engage on first press. Mostly happened when I first got it earlier this year.

Sent from my Pixel 2 XL using Tapatalk
 

·
Registered
Joined
·
519 Posts
My 08 does the same. I've also noticed that sometimes CC will not engage on first press. Mostly happened when I first got it earlier this year.

Sent from my Pixel 2 XL using Tapatalk
My 08 has been the same since I bought 2nd hand 6 years ago at 12,000 miles. I'm guessing that your CC engage button was a little dirty or from non-use when you first bought it but is working now since it's being used more. Electronic cleaner works wonders on these sticky Wing buttons.
 
1 - 7 of 7 Posts
Top