GL1800Riders Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi Guys, first post I believe on here. Got a problem with my 2012 GW crise control. Light comes on when button engaged but will not set. Have consulted the manual and know basically what to do to check it but it is cryptic at best to understand and wondered if anyone on here could direct me to a good video on the process. Have only been able to find a grainy old one on YouTube but doesn't help much as I think he is working on a different model. Anyone help? Am here in the Sunshine Coast in QLD Australia.


Peter
 

·
IronMan
Joined
·
17,634 Posts
Try on here . Do advanced search n see what comes up
 

·
Registered
Joined
·
2,046 Posts
Welcome to the board help should arrive shortly. We have a great group of people willing to help. Just be patient they will answer.... best of luck
Joe
 

·
Registered
Joined
·
2,643 Posts
Switches !!!

One or more of the control switches are / is not releasing. Check the clutch switch, front brake handle switch or the rear brake light switch. If you have changed your clutch handle with an after-market, I would start there.


Easy fix, just time... :grin2:
 

·
Registered
Joined
·
2,046 Posts
How often have you used the cruise control? The buttons are notorious for not making contact is not used. Cleaning and working with plastic safe contact cleaner may fix it providing nothing else wrong with cables and the control unit...
Make sure the brake lights aren’t sticking and there is a micro switch at the clutch handle that disengages the cruise control as well...
 

·
Registered
Joined
·
460 Posts
Welcome Peter!
I had an issue on my 07 cruise, ended up being the aftermarket break lever the original owner installed. Bought an OEM and the problem was gone. Probably not your issue but the switches are very sensitive.
 

·
Registered
Joined
·
199 Posts
How often have you used the cruise control? The buttons are notorious for not making contact is not used. Cleaning and working with plastic safe contact cleaner may fix it providing nothing else wrong with cables and the control unit...
Make sure the brake lights aren’t sticking and there is a micro switch at the clutch handle that disengages the cruise control as well...
^^^This.
You should hear the micro switches click on the clutch and front brake when you pull them.
I'm betting on the contact cleaner.
 

·
Registered
Joined
·
290 Posts
Welcome from the USA!

The cruise control ON light is amber and will light up when the system has power. The cruise control SET light will be green when the system is in control.
The most common issues that keep the system from going green are:
1. Micro switch on either the clutch lever or hand brake lever. If they are working correctly you can hear two clicks when pulling in the levers. These clicks are a little difficult to hear.
2. As mentioned, sometimes after market levers can cause a problem because they do not allow the micro switch "button" to come back out. Sometimes i have to push one of my levers out a few times to let the switch reset.
3. Worn brass bushings in one of the levers will also cause this. It will allow too much play and not allow the lever to go back into the proper position.

Personnally, I have had to replace a couple of micro switches that just got tired of working.
Good luck on solving your problem.
 

·
Registered
Joined
·
2,786 Posts
If you had the brake recall done, it could be the switches on the rear pedal are not adjusted correctly. There were many instances of this. They work sometimes.
There are 3 switches altogether. Clutch, front brake and rear brake. Just because you can hear the click, it doesn't mean they are making contact.
 

·
Soon to be Former Member
Joined
·
7,732 Posts
I had same problem. Turned out that the screw that holds brake lever on was loose, so was screwing with cruise. I tightened screw, problem solved. Hopefully your fix is that easy.
 
1 - 11 of 11 Posts
Top