GL1800Riders Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2,162 Posts
Discussion Starter #1
My cruise doesn't work. It worked intermittently for a while. The brake and clutch lever bushings have been replaced recently so they are OK. Stock levers, not aftermarket ones. I cleaned the 4 switches on the clutch and hand brake and checked them with an ohm meter. They are all functioning. I cleaned the cruise set switch too. The cruise control light is on but the cruise set light won't work. If I push the set switch enough times the light will sometimes flash or come on for only a few seconds. While the light is on the cruise will work but it only lasts a few seconds. Does anyone knowwhere I should look next?
Thanks for any help.
 

·
Registered
Joined
·
1,715 Posts
Check out this thread!

I'll bet it's an easy fix... and I'll bet the answer is in that thread.

Good luck!

Bob
 

·
Registered
Joined
·
476 Posts
cruise

Mine did he same thing. Having new bushing could have pushed your levers out where they are not engaging the micro switches. Take the clutch lever off and put a thick layer of tape on the spot that touches the micro switch and see if this works.
While you have the lever off, look for the micro switch and manually push it in and out to hear it click to see if it stuck. Hope this helps.
 

·
Registered
Joined
·
2,668 Posts
Battery.... my cruise started to malfunction and would not engage, etc... and the reverse would not work properly... then the battery died. I changed the battery and everything worked fine.

Change the battery.
 

·
Registered
Joined
·
325 Posts
I cleaned the reed switches on the hand brake, and the clutch lever with contact cleaner, my cruise worked after that. If it did not work, then I would have gone and cleaned the switch on the rear foot brake.
 

·
Registered
Joined
·
7,613 Posts
1 - 9 of 9 Posts
Top