GL1800Riders Forums banner
  • Hey everyone! Enter your ride HERE to be a part of MAY's Ride of the Month Challenge!

1 - 7 of 7 Posts

·
Registered
Joined
·
440 Posts
Discussion Starter · #1 ·
Left on a 4 day trip, got on the interstate turned on the curise control. Curise light turn on then pushed the set button and nothing. After stopping for gas removed cover and checked fuse. Fuse OK.

The system as worked flawless for ever. Any ideals what to check.



.
 

·
Registered
Joined
·
8,095 Posts
Try pushing out on your clutch and front brake levers.
 

·
Registered
Joined
·
94 Posts
I've had to do the same and push out on brake lever only. (right side) there is a switch that gets stuck, you can also get contact cleaner and spray it. This also works for the radio switches and the switch behind the clutch lever when you can not start it with out putting it into nutural.
 

·
Registered
Joined
·
440 Posts
Discussion Starter · #4 ·
You guys are probly right but I think it might be my foot brake level since I've been screwing around with that since I've been have some brake problems.


.
 

·
Registered
Joined
·
440 Posts
Discussion Starter · #5 ·
You guys are GOOD. Problem was the switch on the foot pedal, adjust it so switches are now depressed.

My problem is I just rode 1000 miles with my brakes light on for all that time, That sucks.


.
 

·
Registered
Joined
·
19,161 Posts
Try pushing out on your clutch and front brake levers.
:agree: Mine do the same thing. If it won't set, push out on the break and or clutch lever and it should work!:thumbup::thumbup::thumbup:
 

·
Registered
Joined
·
527 Posts
cruise cntrol not working

The bushing inside the brake lever wears out so it doesn't make proper contact to activate the cruise function. Had same problem with my 03 at 70k miles.
 
1 - 7 of 7 Posts
Top