GL1800Riders Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Greetings
My fog lights work, but the button only works when pushed in 1/4 - 3/4 of the way. It doesn't "click" on and stay on. I tried electronic cleaner — both around the button and in the back. Also tired the old "Hold the button down with duct tape" trick. That lasted about 15 minutes. Necessity being the mother of invention I got a brain fart: a drywall picture frame hanger. Go figgure.

I had to bend the curved hanger part out a bit from it's OEM positioning:rolleyes:, finding too that a 90 degree angle was too much. I slipped the hanger part into that little slot on the right edge of the larger panel (see photo) and put the flat part against the button. Voila, it holds it very securely. The second image shows the correct size of the hanger (top hanger 1.25" long). The hanger part of the lower example (the 1-1/8" long hanger) isn't long enough to hook properly.
Gadget Automotive lighting Gas Automotive tire Electronic device
Handwriting Ruler Office ruler Font Wood
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Not quite clear from your description. Did you remove the switch plate assembly, open the "black box" enclosure that houses the switches, remove that specific switch, and spray electronic cleaner (some swear by WD-40) on the inside of the switch itself? I don't think spraying electronic cleaner from the front side or the back side (through the holes of the enclosure) will be able to get to the sticky bits.
I pulled off the panel, opened the black box and sprayed in the area of the switch, behind the button. Given that the bike is a new to me 2004, I'm finding things feel a little brittle so I am hesitant to start torquing on plastics that haven't been torqued on in years. Once funds allow I will order another switch and button.
 
1 - 2 of 2 Posts
Top