GL1800Riders Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
517 Posts
Discussion Starter #1
OK I have the seat off and am looking for the white connector in a boot behind the relay box. found a female connector in the left side boot that looks exactly like the EC bike to box connector. I mean exactly - the connector on the EC wire is also a Female white connector so obviously it can't plug in . I've looked everywhere and cant find any other connector Am I missing something or did EC screw up and send me the wrong sex connector?
Thanks
 

·
Legend in His Own Mind
Joined
·
4,671 Posts
I don't know it for a fact but I seem to remember....................................................................................... a post about a few EC kits coming with a wrong connector end. I'd say call Lewis and ask to be sure.
 

·
Registered
Joined
·
3,833 Posts
OK I have the seat off and am looking for the white connector in a boot behind the relay box. found a female connector in the left side boot that looks exactly like the EC bike to box connector. I mean exactly - the connector on the EC wire is also a Female white connector so obviously it can't plug in . I've looked everywhere and cant find any other connector Am I missing something or did EC screw up and send me the wrong sex connector?
Thanks
It was mentioned in another thread that EC sent out some kits with the wrong connector.Sounds like you got one.
Give them a call,they will make it right.
 

·
Registered
Joined
·
517 Posts
Discussion Starter #4
I've just sent an email out to LEwis to find out - had a look at Fred's install pictures- definitely a different connector
 

·
Registered
Joined
·
517 Posts
Discussion Starter #7
Just a note I sent Lewis an email last night and hes already sending me a new cable. Great service - he'll survive the recession
 
1 - 7 of 7 Posts
Top