GL1800Riders Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
927 Posts
Discussion Starter #1
I have been using the Mic-Mutes system on my 06 GoldWing for about 6 months and feel that it is one of the "must have" accessories. I just installed the EC Platinum Driving lights that I got from Hals last sale. I think that I feel like most of the others that have installed them that they are a great addition, easy to install, a pain in the butt to aim, and that the lens guard is junk. I did however run accross a problem that when I turned the driving lights off the Mic-Mutes would cycle. I had noticed during the installation that when I turn the driving lights off I could hear a rather loud "snap or pop" that I though was the just the relay clicking and that it was normal. Upon further investigation I found that the "snapping " would occur no matter if the lights themselves were connected or not. With the Mic-Mutes cycling I started thinking that perhaps I was getting a voltage spike from the driving light relay coil. I call Electrical Coonection and was told that this voltage spike does occur in some installations and that they would send me a diode kit to install free of charge. I just got done installing the diode and now there is no "snapping" or Mic-Mute cycling when I turn off the driving lights. The people at Electrical Connection are well versed in their product and are willing to stand by their product and make it work for you. For this I say "THANKS EC".
Ride Safe
Ken
 

·
Registered
Joined
·
378 Posts
I installed by EC Platium fog lights tonight and noticed the same popping noise when I turn the lights off. When call EC tomorrow to register for the extended warrenty and bulb I will request the diode kit to elimate the popping noise. Thanks for the info.

 

·
Registered
Joined
·
589 Posts
Hmmm. I have mic mutes and platinum lights. I get a popping noise in my headset whenever I have the CB on and I hit a bump. I had thought that it might be a loose connection somewhere. Could it be the light circuit?
 

·
Registered
Joined
·
1,928 Posts
no that is just what I had read on a thread here. Seems to be normal for ABS. I will try to search it out.
 

·
Registered
Joined
·
378 Posts
Num8ber2003 said:
I installed by EC Platium fog lights tonight and noticed the same popping noise when I turn the lights off. When call EC tomorrow to register for the extended warrenty and bulb I will request the diode kit to elimate the popping noise. Thanks for the info.

I received my spare bulb and diode kit from Electrical Connections today. After installing the diode the popping noise is gone. Everything seems to be working ok.
Thanks to Debbie and Phil at Electrical Connections for the fast delivery and the diode kit. :D
 
1 - 8 of 8 Posts
Top