GL1800Riders Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
931 Posts
Discussion Starter #1
Was riding today when I noticed my dash left turn signal indicator came on constant, not flashing.

I could not cancel it.

Turned on the right signal -- same thing, on constant, not flashing.

So, either the left or right is on constant, no flashing. This includes front and rear turn lights themselves.

Pressing the 4-way flashers causes all of the lights to come on, no flashing.

A search showed a lot of '05s seem to be having turn signal issues but none were quite like this.

I have an '05 ABS model with 75K. No bulbs are burned out. Turn signals are "stock." I've not been under the top shelter for about 2,000 miles nor recently washed the bike or ridden in significant rain.

If the flasher unit went bad, would that cause this problem with both the turn signals and 4-way flashers?

The turn signal switch "feels" okay but I've not tested it and I'm not sure a bad turn signal switch would keep the 4-ways from working anyway. Same with a bad relay.

Any other ideas?

Thanks.
 

·
Registered
Joined
·
201 Posts
check the flasher first
 

·
GL1800 Doctor
Joined
·
20,216 Posts
Bob, I'm afraid your flasher has crapped out. The same flasher is used for the turn signals as well as the 4 ways.
 

·
Registered
Joined
·
931 Posts
Discussion Starter #8
To follow up -- took the bike to dealer, using the extended warranty. The tech got as far as checking the diodes when everything started to work again and is continuing to work. So either a connection was loose/dirty or a part of the circuit is starting to flake out -- hopefully the first.

I'll find out soon enough maybe, as I'm leaving Friday for Buffalo, NY for CP#1 of the in-progress IBR.

Again, thanks for the feedback and ideas.
 
1 - 8 of 8 Posts
Top