GL1800Riders Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
355 Posts
Discussion Starter #1
I noticed the trunk was kinda hanging on something yesterday. Blocking it from aligning correctly. I opened and shut it a few times and same thing. I got to looking and where the wires come from the trunk to the lid there is a wire clip that should hold the cabled/covered wires in place as the trunk opens etc. This clip had broken off and was causing the lid to shif over some. Removed it and it shuts fine. So being how the bike is under warranty is this something I ought to take care of or just forget it? Or just postpone it until the one day when I actually take the bike in for something underwarranty. What'cha think?
 

·
Banned
Joined
·
11,396 Posts
The Trunk Hinge is defective.
I'd get it replaced under warranty.Drop by the dealer and show it to them and ask them to order one and let you know when it's in so they can swap it out (Less than a 1/2 hour) while you wait.:shrug:
 

·
Registered
Joined
·
2,731 Posts
The Trunk Hinge is defective.
I'd get it replaced under warranty.Drop by the dealer and show it to them and ask them to order one and let you know when it's in so they can swap it out (Less than a 1/2 hour) while you wait.:shrug:
What Rocky said...
If those clips are missing you could end up with wires in the wiring harness breaking, and end up with all kinds of electrical problems. Brake lights could go out, speaker could stop working, etc. I'd get it fixed ASAP.
 

·
Registered
Joined
·
355 Posts
Discussion Starter #5
Fixit

Thanks. I will. I was on the fence only because I didn't want to over react or anything but those thoughts crossed my mind. So you have confirmed my thoughts.

Thanks
Happy riding...
 
1 - 5 of 5 Posts
Top