GL1800Riders Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I replaced the battery on my 1800, turn key and engaged the switch to start but nothing. ALL dash lights and surrounding lights function but nothing happens when I engage the starter. Any suggestions?
 

·
Registered
Joined
·
977 Posts
Check the kill switch. Make sure it is in the run position. Maybe the contacts in the switch are oxidized and not making contact.
 

·
Registered
Joined
·
332 Posts
Side stand down in gear will not make it start.
 

·
Registered
Joined
·
821 Posts
Check tightness of battery cables to battery terminals. Was or is there any corrosion on terminals from old battery?
Check all that has been mentioned in above post.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #6
Would like to say thanks to all that replied; after I sent the request I went and sat just to stare and go over all that it could be one more time. I started at the bottom working my way up and of course I should have started at the top....lol
@MichaelB - the kill switch was the problem. Apparently I must have bumped it and it was in-between settings and I never noticed it till I did my recheck. So again I appreciate all the quick replies and hopefully I'll be able to help someone also.
 

·
Registered
Joined
·
3,276 Posts
Just happened to me today. I went to Sam's club, parked it in gear as usual and on the side stand.
I put up the kickstand, pulled in the clutch and NOTHING. All lights normal. I checked the usual, but decided to put it in Neutral, and she started just fine.
It wasn't the Kill Switch, Side Stand, or anything else like that. Possibly, I may not have pulled the clutch in far enough....at least, that was my suspicion.
That was the only difference, so there must be a switch associated with that.....I'll read up on it this winter. Has anyone else experienced that ?
 

·
Registered
Joined
·
332 Posts
Just happened to me today. I went to Sam's club, parked it in gear as usual and on the side stand.
I put up the kickstand, pulled in the clutch and NOTHING. All lights normal. I checked the usual, but decided to put it in Neutral, and she started just fine.
It wasn't the Kill Switch, Side Stand, or anything else like that. Possibly, I may not have pulled the clutch in far enough....at least, that was my suspicion.
That was the only difference, so there must be a switch associated with that.....I'll read up on it this winter. Has anyone else experienced that ?
Might be a dirty clutch lever switch. Mine did the same thing. Tried to start it in gear with the kickstand up and no start. Let the clutch lever out and then pulled it in then it started. Took the switch off cleaned it with electrical contact cleaner spray and it’s been good to go every since.
Good luck!!!
 
  • Like
Reactions: n9frp

·
Registered
Joined
·
2,795 Posts
Just happened to me today. I went to Sam's club, parked it in gear as usual and on the side stand.
I put up the kickstand, pulled in the clutch and NOTHING. All lights normal. I checked the usual, but decided to put it in Neutral, and she started just fine.
It wasn't the Kill Switch, Side Stand, or anything else like that. Possibly, I may not have pulled the clutch in far enough....at least, that was my suspicion.
That was the only difference, so there must be a switch associated with that.....I'll read up on it this winter. Has anyone else experienced that ?
You likely pulled the clutch in far enough.... the clutch does have a switch behind it that, if dirty or defective, will fail. This switch is required to start the bike in gear and if it fails, the bike thinks you are trying to start the bike in gear and the clutch out... Common problem and likely all you need to do is pull this switch, one screw, and clean it with some contact cleaner.

Is likely, putting the bike in neutral will bypass this switch.
 

·
Registered
Joined
·
808 Posts
Caused by a bad crush washer.


In reality my 2005 has done it a couple of times. Going to clean clutch lever along with other little projects over the winter.
 
1 - 11 of 11 Posts
Top