GL1800Riders Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1 (Edited by Moderator)
My father has a sound coming from the water pump occurs only at idle and only when the bike is at full temp. It sounds like a bird chirp/whining noise. If you raise the rpm from idle just by 100 rpm or more it goes away. Rpm goes back to idle and noise again. Checked alternator and all is fine there. No coolant leaks either. Coolant was serviced 15k miles ago. Does he need a new water pump or can it be solved by doing an acid flush and adding good coolant?
 

·
Registered
Joined
·
4,982 Posts
My 08 did the exact same thing at 100k. I think it was the thermostat but the pump and thermostat are one assembly. I changed it out and all was well. Not too hard of a job.

Sent from my moto g stylus using Tapatalk
 

·
Vendor
Joined
·
17,410 Posts
My father has a nice goldwing with 94k he is selling and recently a sound coming from the water pump occurs only at idle and only when the bike is at full temp. It sounds like a bird chirp/whining noise. If you raise the rpm from idle just by 100 rpm or more it goes away. Rpm goes back to idle and noise again.
I've recorded and posted that sound on my You Tube channel here. If it sounds similar, it is a failing water pump. The only repair is to replace the water pump assy.

 

·
Registered
Joined
·
4,982 Posts
That's what it was not too bad to change out....Thank you everyone
I had a small oil leak after changing mine... I had pinched the o ring putting it together, had to redo the entire job. A lot easier the second time! :)
 
1 - 6 of 6 Posts
Top