GL1800Riders Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
147 Posts
Discussion Starter #1
Seems bikemp3 has resolved the cb issue. I just ordered my cb that won't be shipping until at least the second week of June. $429.00 is a much better price than the $800 to $1000 for the OEM. Hope the quality is as good as what I have been reading about the earlier versions.......waiting is going to suck, but I'm sure I won't melt....lol
 

·
Registered
Joined
·
101 Posts
Installed my Gl2way early last year, bought from cyclemax... not a problem with it at all. works well and far cheaper than OEM.
 

·
Registered
Joined
·
129 Posts
I have had the GL2Way for about 2 years. I've been very happy with it up until the end of last year when it developed a problem and was working erratically. I sent it in to be fixed and they told me I needed a new board but was not going to fix it due to the new design was coming out. They told me 8 weeks in production and now you are saying the 2nd week of June. The problem is that I am leading a group of people out to Utah on June 13th and need something to use. I have been in manufacturing for many years and I know what can happen to the "order fill" date. Always problems to contend with. I am not sure how to handle this as I can not leave town without one.
BikeMP3 has always treated me right and by looking at some of the responses in the past, most people feel the same way. I am just hoping they can pull this one off:shrug:
 

·
Registered
Joined
·
1,133 Posts
Well if you are familiar with the hook up of the GL2way I am riding from texas to wisconsin in about 4 weeks
to tow a small bike to rail.. IF you know the magic trick to quash the squeal in my GL2way you may use it until you get your fixed.. I wont need it until I ride my 4 corners ride & 3 flags ride end of August
Is that squeal only when you transmit? I have the same issue. IS there a fix for it? Others that I ride with grab their helmets when I transmit as all they get is a loud squeal.
 

·
Banned
Joined
·
2,968 Posts
Is that squeal only when you transmit? I have the same issue. IS there a fix for it? Others that I ride with grab their helmets when I transmit as all they get is a loud squeal.

Your issue is there is either something missing on your install or something amiss in the bike wiring wrapping in foil will not help you, his issue is a 2012+ bike problem
 

·
Registered
Joined
·
2,556 Posts
Is that squeal only when you transmit? I have the same issue. IS there a fix for it? Others that I ride with grab their helmets when I transmit as all they get is a loud squeal.
On the OEM radio there can be a feedback squeal..... Sierra Electronics has my output power set at about 70% for this reason..... Cheers....:doorag:
 

·
Banned
Joined
·
2,968 Posts
Will cutting back the power on the gl2way help the same way??
Possibly but the OEM unit has the same issues, also you need to stop hijacking these threads on CB's its confusing the questions being asked please try to stick on one thread so we can help you have you tried all the suggestions we made on the last post
 

·
Registered
Joined
·
2,556 Posts
Possibly but the OEM unit has the same issues, also you need to stop hijacking these threads on CB's its confusing the questions being asked please try to stick on one thread so we can help you have you tried all the suggestions we made on the last post
:popcorn: :shrug: I'm confused..... please explain..... Cheers....:doorag:
 

·
Banned
Joined
·
2,290 Posts
My appologies to any and all, I did not realize I had hijacked the post by offering my unit to another member for his trip
And yes i did try the things listed in the other posters threads, as best as I could confusing,, still squealing worse than a pig at market
 

·
Registered
Joined
·
1,133 Posts
Your issue is there is either something missing on your install or something amiss in the bike wiring wrapping in foil will not help you, his issue is a 2012+ bike problem
found the issue Pete. The new short cable you sent me did not have the filter installed on the larger cable. I removed the filter from the old cable and installed it on the new cable and the squeal is gone.
 

·
Registered
Joined
·
401 Posts
on order - new GL2Way Evolution

Ordered mine on day one as well (love that discount method Pete - good job). I just finished (moments ago) the Sierra single antenna kit installation. I am going to start another thread on that. But I am looking forward to getting the new radio. I too have a ride in June - so I am crossing my fingers.
...gene
 
1 - 12 of 12 Posts
Top