GL1800Riders Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3,178 Posts
Discussion Starter #1
At 92K the heated seat on my 07 stopped working. The grips still work great as long as you do not turn on the seat heater. If you turn on the seat it shuts everything down until you turn off the ignition and restart and then the grips function again. I have checked connection under the seat and fuses.

Suggestions appreciated. I do not plan on spending a lot of time or money fixing this problem as I use the grips more than the seat. If I can find a heated seat to swap out that could answer some questions. Thanks for all input.

Fred
 

·
Registered
Joined
·
7,389 Posts
Electrical connection sells a jumper that you can use to jump out the seat connector, however it sounds like that portion of your seat is working (the sensor section). Since you turn it on and everything shuts down, sounds like you may have a shorted wire - pulls excessive current and shuts the system down. There are heated seats showing up from time to time here on the board, and you may find someone with a really beat up seat (cover wise) that still has a good heating element that will send the seat to you for the cost of postage. Then you can pull the covers off and swap them (covers or heaters).

I do have a heated seat and backrest I can loan you to assist with your troubleshooting if desired. Wife is wanting to take a drive up north towards Vasser - maybe I can drop it off if interested. Offer's open - let me know.
 

·
Registered
Joined
·
1,315 Posts
mine was doing the same thing..........dealer replaced the left grip and everything works fine now.
 

·
Registered
Joined
·
3,178 Posts
Discussion Starter #5
Electrical connection sells a jumper that you can use to jump out the seat connector, however it sounds like that portion of your seat is working (the sensor section). Since you turn it on and everything shuts down, sounds like you may have a shorted wire - pulls excessive current and shuts the system down. There are heated seats showing up from time to time here on the board, and you may find someone with a really beat up seat (cover wise) that still has a good heating element that will send the seat to you for the cost of postage. Then you can pull the covers off and swap them (covers or heaters).

I do have a heated seat and backrest I can loan you to assist with your troubleshooting if desired. Wife is wanting to take a drive up north towards Vasser - maybe I can drop it off if interested. Offer's open - let me know.
That sounds great, let me know when you plan on making the trip and I'll meet you as it looks like Vassr is about 1.5 horurs away from me. If your seat works on my bike then I'll know my problem involves the seat itself. Thanks so much for the offer. contact me at [email protected]

Fred
 

·
Registered
Joined
·
832 Posts
My grips also worked fine unless the seat was turned on. The problem was a broken wire in one of the heating elements in seat. Removed the cover and repaired the wire. Have only rode about 1000 miles after repair but still working fine.
 

·
Registered
Joined
·
3,178 Posts
Discussion Starter #7
My grips also worked fine unless the seat was turned on. The problem was a broken wire in one of the heating elements in seat. Removed the cover and repaired the wire. Have only rode about 1000 miles after repair but still working fine.
Thanks for the response I suspect that's what it is as I have 92K worth of butt miles on the seat lol. ssncob has offered to loan me his spare seat and that will tell me for sure.

Fred
 

·
Registered
Joined
·
7,389 Posts
When I had my seat redone by Tom Simmons he said he sees a lot of the seats where the rider has sat on the riser section at the back of the seat (the lower back section) and has broken the wires there. Just an info item.
 

·
Registered
Joined
·
832 Posts
Mine was a broken wire on the left wing of riders seat and was a fairly simple repair. While I had the cover off I also lowered/reshaped the seating area by removing some foam.
John
 

·
Registered
Joined
·
3,178 Posts
Discussion Starter #10
Update: ssncob was kind enough to loan me his spare OEM heated seat and I swapped it out with mine today and went for a ride. The seat worked perfectly which tells me my problem is in my drivers seat heating element.

Hope this helps out anyone with a similar problem.

Fred
 
1 - 11 of 11 Posts
Top