GL1800Riders Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
231 Posts
Discussion Starter #1










1 Hour Ago #1 ROADDOGG




























No brakelights




Hi guys this is my situation!. wanted to go for a ride and wanted to pull trailer. So hooked up trailer to bike on inspecting the brake,turn sigs, stop lights etc. found i have no brake lights. only the brake light on the trunk spoiler and by the trunk latch the kind from kury lite up. The trunk lights and the saddle bag brake light wont come on only the running lights. Turn signals work fine,flashers,running lights. no brake light except as mention earlier. I do as you know have a trailer harness. checked the fuses all were ok!. Im at a lose for words on how to fix this have missed out on a beautiful day but will not ride with out the proper lighting. Can some one help me please. Thank you!.:shrug:​




__________________​







Public ProfileSend a private message to ROADDOGGFind More Posts by ROADDOGGAdd ROADDOGG to Your Contacts









1 Hour Ago #2 JohnACman





Seasoned Member​





Join Date: Jul 2007​




Location: Orlando, Fla.​




Posts: 2,667​










Sounds like the brake light relay is either stuck or burned out. If you have brake light modulators on them, the modulator might be burned out. Brake relay is under the seat. Remove seat and listen for a click in the relay when you apply pressure to the brake lever.​




__________________​




06, Dark Red GL1800​




Darksider #107​




Kumho 195/55/16 Run Flat (30psi) 2nd one​




Pirelli Sport Demon 130/70/18 Bias (40psi)​








We are All pulling for you, Bev.





lic ProfileSend a private message to JohnACmanSend email to JohnACmanFind More Posts by JohnACmanAdd JohnACman to Your Contacts










1 Hour Ago #3 ROADDOGG





Seasoned Member​










Join Date: Oct 2006​




Location: POWDER SPRINGS GA.​




Posts: 235​










Quote:​













I dont have mods on the brakes only the spoiler on the trunk its the only one the brake lite works on. the factory lights dont light up when i hit the brakes​




__________________​








iew Public ProfileSend a private message to ROADDOGGFind More Posts by ROADDOGGAdd ROADDOGG to Your Contacts










4 Minutes Ago #4 ROADDOGG





Seasoned Member​










Join Date: Oct 2006​




Location: POWDER SPRINGS GA.​




Posts: 235​










i checked under the seat and heared the relay clicking when i pressed the brakes on top and bottom. so i swap some of them around and still the same. all of the relays on the second row are the same. i still dont have any brake lites except on the trunk spoiler and handel. the kury mud flap and license plate are not working either they are on but the brake lite portion is not coming on HELP PLEASE:shrug::bow:​




__________________​
lic ProfileSend a private message to ROADDOGGFind More Posts by ROADDOGGAdd ROADDOGG to Your Contacts


















 

·
Registered
Joined
·
260 Posts
If upon unplugging the trailer harness you still do not have brake lights on bike, you have a blown fuse in the brake light circuit.
 

·
Registered
Joined
·
3,033 Posts
I'm on the road and can't confirm.... but I believe the brake light signal wire
splits under the seat and goes through different connectors to the spoiler and bag brake lights.
Since the spoiler brake still works.... it would have to be in the leg that splits off to the bags.
I would check the connectors under the seat (on the right side near the seat mounting bolts I think....
If no joy there.... you may want to pull the rear filler piece between the bags (holds the license plate) and check nothing has damaged the wiring there....
I seem to remember some reports of a pin getting burned or corroded in the connectors under the seat..... that carried a ground wire associated with the lighting.
Good luck!!!!!!!
 
1 - 4 of 4 Posts
Top