GL1800Riders Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 9 of 9 Posts

·
Registered
Joined
·
613 Posts
Discussion Starter #1
I seen the Showchrome led mirror trim at wingding and thought it added lots to the mirrors as it has turn signals that are visable to the side. I just tried to put them on today and besides the 2 sided tape being unusable the blinkers do not blink when you turn them on. They come on when you start the bike but when you turn on the turn signal the side you turn on goes out, no blink, the light on the front side of the mirror still blinks.
ANY IDEAS?
 

·
Registered
Joined
·
1,853 Posts
Low on blinker fluid???? :yes:
 

·
GL1800 Doctor
Joined
·
20,548 Posts
You connected them to the position light's hot wire instead of the turn signal hot wire. There's 3 wires behind the mirror, 1.ground, 2.turn signal hot, 3.position light hot.
 

·
Registered
Joined
·
613 Posts
Discussion Starter #5
They are plug and play just unplug the turn signals in the mirror and it plugs into the same place.
 

·
GL1800 Doctor
Joined
·
20,548 Posts
If that's the case, then Showchrome built the connectors wrong. Look at the wires coming from the LEDs, one of them should go to the green wire in both mirrors and the other wire should go to the solid orange wire on the left side and the solid light blue wire on the right side. The wires that have a white stripe on them are the position light's hot wires and the LED shouldn't be going to them or you get the symptom you have.
 

·
Banned
Joined
·
11,396 Posts
They are plug and play just unplug the turn signals in the mirror and it plugs into the same place.
Looks like you didn't buy the blinker adapter.:shrug:

Look at your receipt and call the vendor or showchrome on Monday.


They should be blinking wth the trunsignal,unless the wires in the connector aren't in the right slots.:shrug:
 

·
Registered
Joined
·
613 Posts
Discussion Starter #8
instructions dont show any adapter, just plug n play. they come with 2 plugs, one to plug to the bike and one to plug the plug from the mirror turn signal. I dont see any way to mess it up. they only go one way, cant reverse them, they wont fit.
 

·
Registered
Joined
·
307 Posts
But they might have screwed up when they put the wires in the connecters. Like Rocky said. Call the vendor on Monday to see what they say.
 
1 - 9 of 9 Posts
Top