GL1800Riders Forums banner
  • Hey everyone! Enter your ride HERE to be a part of August's Ride of the Month Challenge!
1 - 4 of 4 Posts

·
Registered
Joined
·
5,385 Posts
Discussion Starter · #1 ·
Just bought the wife a replacement XS Gerbing jacket. Her tourmaster died. I can not figure out the wiring. It seems that if I plug in the main, the jacket works but the tourmaster gloves will not (single controller). I tried plugging in the "Glove" and "accessory" plugs into each other but still no heat at the gloves. Is there a secret to getting the gloves to work? Do the "Glove" and "accessory" plugs need to be plugged into each other or must I have a dual controller for the gloves to work?
 

·
Registered
2008 GL1800 2nd Gen
Joined
·
1,571 Posts
Glove plugs into the corresponding arm, plug in each sleeve. The jacket (Red) plug works both gloves and jacket at the same time off the red side of a dual controller.

It is possible that the new jacket and controller are the new style micro wire and the gloves are the old style, which won't work with the micro wire due to different amp draws.

What I found out when I tried to replace old and new style. Eventually went with all new with warm and soft.

Hope this helps.
 

·
Registered
Joined
·
5,385 Posts
Discussion Starter · #3 ·
Glove plugs into the corresponding arm, plug in each sleeve. The jacket (Red) plug works both gloves and jacket at the same time off the red side of a dual controller.

It is possible that the new jacket and controller are the new style micro wire and the gloves are the old style, which won't work with the micro wire due to different amp draws.

What I found out when I tried to replace old and new style. Eventually went with all new with warm and soft.

Hope this helps.
It may be that the new jacket might not be new. I bought it used "worn only once". It does look brand new but I suspect it uses wires while my 4 year old tourmaster gloves I believe are carbon fiber. I installed a splitter off of the controller and plugged in the jacket and the gloves plugs seperatly, all seems to work now.
Thanks
 

·
Registered
Joined
·
2,680 Posts
Same Issue

Rob, I have the same issue as you. I have a Gerbing Jacket Liner that is pushing 15 years old. The liner has two circuits, one for the jacket and one for the gloves. I use a dual controller with one circuit for the jacket and one for the gloves. Whenever I turn on/up the gloves, the jacket gets cool. Whenever I turn on/up the jacket, the gloves gets cool.
Been this way since day one and Gerbing never could figure out why and when asked on this board, same results. I hear this is somewhat a common complaint. :crying:
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top