GL1800Riders Forums banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 15 of 15 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all,,,,
I have a 2004 GL1800,,,,
I’ve searched thru the various sections and couldn’t find any similar post,,,,,
I purchased a J&M digital music player to replace the six changer CD player that wouldn’t release the cd I have in it, nor take any new ones.
I pulled out the CD player, disconnected the plug, plugged the J&M unit in its place as per instructions,, loaded up a usb stick of a few songs, turned on the ignition, pushed the cd button and nothing happens! My radio channels and CB all work, just no response when I push the cd button,, no beep or anything. I had the CD player playing a month or so ago so I know it was working. I called tech support at J&M and they’ve never had such an issue.
Any ideas???
I checked the pins, all straight and accounted for, no apparent damaged wires…… not happy!!!
Thanks for any help!!
 

·
Registered
Joined
·
872 Posts
Vague help from me. I had the same type of player from a different company on my '05. It would occasionally lock up. The seller thought it might be because I had accidentally pushed the CD and another button at the same time. I was doing this when I sat my helmet on the dash. The only way to fix mine was to disconnect unit from power and connect again. Hopefully this will help. I did not have a CB.
 

·
Registered
Joined
·
8,415 Posts
I believe there are several versions of the J&M Music player. I have one. It takes a USB thumb drive or an SD card. I've never tried USB but the SD card works. There's a reset button on it that I've never had to use. I don't think there's a light on it to indicate power.

So the display doesn't show CD player being on or anything? Can you try another input like a SD card? Is it a brand new unit or did you buy it used?
 

·
Registered
Joined
·
5,271 Posts
Hi all,,,,
I have a 2004 GL1800,,,,
I’ve searched thru the various sections and couldn’t find any similar post,,,,,
I purchased a J&M digital music player to replace the six changer CD player that wouldn’t release the cd I have in it, nor take any new ones.
I pulled out the CD player, disconnected the plug, plugged the J&M unit in its place as per instructions,, loaded up a usb stick of a few songs, turned on the ignition, pushed the cd button and nothing happens! My radio channels and CB all work, just no response when I push the cd button,, no beep or anything. I had the CD player playing a month or so ago so I know it was working. I called tech support at J&M and they’ve never had such an issue.
Any ideas???
I checked the pins, all straight and accounted for, no apparent damaged wires…… not happy!!!
Thanks for any help!!
J&M is an advertiser on this website, check with them
 

·
Registered
Joined
·
507 Posts
I have the J&M Music Player and sometimes it would not work and sometimes with me fiddling with it it would. My USB plug in will light up when plugged into the unit and unit is on. Sometimes when I could not hear the unit through the system but it would show the CD spinning in the display. Is your CD showing up in the Display? Remember you are substituting the CD when actually it is the J&M unit. What about your volume and tune buttons on the left side handlebar. Are they functioning? Once I had to rebuild a USB player because the J&M unit quit recognizing it. Remember the root folder is not a folder it can contain up to 95 songs. Then you create 4 more folders and each contain 95 songs. I've had my J&M unit since 2018 on my 2005 and I rode 579 miles this past Sunday and it worked flawlessly.
 

·
Registered
Joined
·
1,755 Posts
If you accidently hit the AUX button, it want work. Unplug the player and disconnect battery for a few minutes then connect battery and then player. Never touch the Aux button .
 

·
Registered
Joined
·
388 Posts
If you accidently hit the AUX button, it want work. Unplug the player and disconnect battery for a few minutes then connect battery and then player. Never touch the Aux button .
I beg to differ on that one. Never had any issue going from CD to Aux and back.

To change tracks or folders, use the buttons on left control, just under the volume switch, NOT the selectors on radio control panel on the tank cover.

Bump once to advance track, hold to change disk(CD folders).

I had the player screw up, as in can't change tracks, select folders, etc. All by itself...only way to bring it back is to cut off the bike and power back up and it always come back online.

J&M tech support acknowledged that issue and there is nothing they can do to correct it. You're trying to "fool the system" and sometimes system says NO WAY, JOSE!!! You no CD player...🤓

If you're using a flash disk, or even the SD card, you MUST load the music as instructed.

"CD1" folder don't exist in folders. Just load the tracks and it will automatically recognize it as tracks in CD1 folder.

Created more folders, CD2-CD6 and load your tracks to each folders.

Keep in mind the folder limit the amount of tracks you can load in each folder per instructions.
 

·
Registered
Joined
·
1,953 Posts
I think you will have to disconnect the battery for a few minutes to get everything to reset. I have a different brand mp3 player. If I hit the ASel button it will not shut off even with the key off. Have to disconnect the battery to get things working again. It does work fine with the handlebar controls. And the previous posters are correct about folders.

Good luck! Let us know if you solve it, and how.


Later,

Rayjoe
 

·
Registered
Joined
·
838 Posts
I believe you have to plug a dongle in first, turn the cd on then off, unplug the dongle and connect the cd. I suggest you call J&M. They should be able to help.
 

·
Registered
Joined
·
317 Posts
I have the same unit. Simply unplug the USB thumb drive from the J&M unit and it resets. No need to pull battery cables. I assume that you used the proper cable? I recall the J&M comes with a cable different than the one that plugs into the CD drive. I unplugged that cable under the seat and plugged in the J&M supplied cable and threaded it thru the hole in the trunk and plugged it into the J&M unit. I have to reset it sometimes (as per above) as it will not flip to the next folder (up or down). Frustrating. Anyways hope this helps.
 

·
Registered
Joined
·
1,126 Posts
Check with the manufacturer but I have a similar device and had to format the USB memory using fat32 format. Perhaps it just removed the included safe drive files, I could delete those items that came on board the stick. I also name the sub-folders 2-6. I use 16gb drives, larger drives are probably not readable by this device. I had issues using 64gb and don't remember if 32gb worked or not but started with 16gb ones. I think it gets frustrated with the larger drives as they have memory addresses it doesn't understand so it stalls in frustration.

Sent from my Moto Z (2) using Tapatalk
 

·
Registered
Joined
·
388 Posts
Check with the manufacturer but I have a similar device and had to format the USB memory using fat32 format. Perhaps it just removed the included safe drive files, I could delete those items that came on board the stick. I also name the sub-folders 2-6. I use 16gb drives, larger drives are probably not readable by this device. I had issues using 64gb and don't remember if 32gb worked or not but started with 16gb ones. I think it gets frustrated with the larger drives as they have memory addresses it doesn't understand so it stalls in frustration.

Sent from my Moto Z (2) using Tapatalk
32Gb works on mine.
 

·
Registered
Joined
·
507 Posts
The key to changing folders is to hold the Tune SW up or down for 5 seconds or more. Just tapping it changes to next song.
 
  • Like
Reactions: PastoT

·
Premium Member
Joined
·
605 Posts
Seems to me that there are 2 USB ports. One is for the flash drive, one for charging...is the flash drive in the right port?
If so, disconnect the battery for a hard reset. For whatever the reason, the audio can and does lock up. A hard reset gets things going again. Might just be coincidence that it locked up when you added the J&M unit.
Make sure that the music is in a file folder that the unit can read. IIRC, just throwing music on a flash drive without a folder does not allow the unit to access files. It needs to access a file folder to work.
 
1 - 15 of 15 Posts
Top