GL1800Riders Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
The bag release acts like it is not even hooked up. Heard there is a recall on the 2006 models. Hope someone can help me out.
 

·
Registered
Joined
·
1,883 Posts
In your trunk on the left side is a small plastic button/cover. Remove that cover(snaps out) and stick your finger into hole and push a button,,,trunk will open. Then search this forum for the left saddlebag fix and cure that problem for good. Fred H. has it on his site.
 

·
Registered
Joined
·
1,883 Posts
I just sent you a PM
 

·
Registered
Joined
·
3,341 Posts
Notorious for breaking. Had mine done twice ans is in need of third time. Its an 08 :eek:4:
 

·
Registered
Joined
·
1,883 Posts
Notorious for breaking. Had mine done twice ans is in need of third time. Its an 08 :eek:4:
If you reposition the latch green plastic thing your problems will be no more.
 

·
Registered
Joined
·
3,341 Posts
? Got pics, I'm game.
 

·
Registered
Joined
·
1,883 Posts

·
Registered
Joined
·
3,341 Posts
Thanks.
 

·
Registered
Joined
·
1,883 Posts
That Fred H. link that I just posted shows quite a bit of detail which I didn't find necessary. Just reposition the green plastic tube into the middle slot and it works fine. It should only take 15 minutes.
 

·
Registered
Joined
·
93 Posts
I replaced the plastic clip, (added small cable tie), adjusted the rods in the saddlebag, etc. The best thing IMO to do is slightly push in on the lid while operating the lever to open it. It takes pressure off the latches and the clips and everything else. Most people seem to be breaking the clips when they over pack the side bags, which puts more pressure on the lids, clips and the rest of the breakable things.

I found out the hard way, now I always put pressure on the lids while operating the levers. No problems in over two years.
 

·
Registered
Joined
·
1,517 Posts
My dealer fixed it in 10 minutes under warranty...he said he needed to adjust something from "5-to 3" ???? I didn't care , just wanted it fixed
and has been perfect since.
 
1 - 13 of 13 Posts
Top