GL1800Riders Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I need help. Just got back from a trip to New Mexico. The day before I was to leave one of my buddies noticed my head light were not working. All other lights were working. Only headlights, high and low beam...Totoally kaputt! After fiddling for hours checking fuses wiring connections etc. nothing was obvious. Then I sarted the bike again and presto....Lights. I thought it was the key (ignition) I giggled it around nothing. Then they went out again after the bike was shut down. As long as the motor was running, if they worked when it was started then they would work, if they did not work when it was started, then nothing I could do anything that would make them work.
Finally I giggled the starter button, and they flashed. I restarted it, they did not come on, I giggled the starter button, and they came on.
I do not understand what is going on.
Something in the starter button is shorting out the light when the engine is started up.
Help! Any suggestions. I really need head lights.
Thanks for your suggestions. I have a 2003 GL 1800.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
Thanks guys,
This was very helpful and makes a lots of sense. I will try cleaning the switch.
By the way I failed to mention that it left me at an Exxon station in Lubbock Texas at 5:00 am in the dark, stuck until sun up ( 7:15).
You guys are great. A true source of knowledge and experience.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top