GL1800Riders Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
312 Posts
Discussion Starter #1
Just installed a set of Muth mirrors and really like them however they don't fit properly. There is a huge gap at the top and they hit the bottom of the housing.Anyone have a similiar problem
 

·
Registered
Joined
·
2,731 Posts
Just installed a set of Muth mirrors and really like them however they don't fit properly. There is a huge gap at the top and they hit the bottom of the housing.Anyone have a similiar problem
Nope. Sounds like you have it in the housing wrong. Mine has an equal gap all the way around. The mirror housings haven't changed on the bikes, so I'm guessing your installation was incorrect. I'd suggest trying to put the oem mirrors back in and see if you have a similar problem. If so, you know the mirrors didn't have that problem before, so it must be operator error.:shrug:

Hopefully no offense is taken. None was intended.
 

·
Registered
Joined
·
19,223 Posts
They should fit nicely. Maybe they are backwards or something
 

·
Registered
Joined
·
5,923 Posts
Just installed a set of Muth mirrors and really like them however they don't fit properly. There is a huge gap at the top and they hit the bottom of the housing.Anyone have a similiar problem
Are you sure you have the right ones? Muths have two different models for different years.
 

·
Registered
Joined
·
312 Posts
Discussion Starter #6
muth

They seem very simple to install and are the exact same size as the factory mirrors. They just sit low. the factory ones go right back in and fit right. I really wish it was incorrect install but I don't think so. Bike is a 2009 and the instructions were for a 2009.
 

·
Registered
Joined
·
1,871 Posts
I installed a set on the '02 Wing and another on the '09 Wing. Both sit/sat in exactly the right position. On the '02, it took a while to get it in correctly as the interior 'nut' wanted to sit in a lower position. Once I got that figured out, it took a few additional seconds to get it tightened up.
 

·
Registered
Joined
·
898 Posts
Mine on my 08 fit perfectly,small gap all the way around.
 

·
Registered
Joined
·
2,731 Posts
I installed a set on the '02 Wing and another on the '09 Wing. Both sit/sat in exactly the right position. On the '02, it took a while to get it in correctly as the interior 'nut' wanted to sit in a lower position. Once I got that figured out, it took a few additional seconds to get it tightened up.
That's what I think the issue might be. The only difference between the different years is the connector for the blinker(AFAIK). I know the 01-05 are different than 06. Not sure if they changed. I agree, a pic would help, I can take a look at mine and see what the issue might be.
 

·
Registered
Joined
·
768 Posts
You can rotate them when mounted on the bike. If you have a loose/tight fit in opposite corners that would be the problem..
 

·
Registered
Joined
·
474 Posts
I think you need to check your install a little closer.
 

·
Registered
Joined
·
384 Posts
I also installed some door edging around each one.

 

·
Registered
Joined
·
2,731 Posts
That's what I think the issue might be. The only difference between the different years is the connector for the blinker(AFAIK). I know the 01-05 are different than 06. Not sure if they changed. I agree, a pic would help, I can take a look at mine and see what the issue might be.
I just pulled mine off and took a look. You have to make sure the screw opening for the 'mirror piece' is 'ABOVE' the little clip where the screw will go though in the housing. If it's 'below', or the clip is 'half above, and half below' you'll have a very tight fit(if you can actually get it in. I would suggest removing the mirror, then making sure the two 'clips' at the top are securely in the holes, then make sure the mirror rests 'above' the piece in the housing where the screw goes in.
 

·
Registered
Joined
·
2,017 Posts
Just installed a set of Muth mirrors and really like them however they don't fit properly. There is a huge gap at the top and they hit the bottom of the housing.Anyone have a similiar problem
You don't have the Muth housing above the wing's bracket. If you grab the mirror you can pull it out as it is not secure. Back out the screw and try again. Make sure the top of the mirror fits in the TOP all the way first then (I have to use a light to see exactly where it needs to go) place the Muth bracket on the TOP of the mirror "housing".

Best of luck.
 

·
Registered
Joined
·
312 Posts
Discussion Starter #17
YELLOW GLIDE saves the day

You were right the mirrors were not installed at the top correctly. Once I read your post it was on easy fix and I love the mirrors.I want to thank everyone for their help. Nobody flamed me, everyone just tried to help and for that I say thanks!
 

·
Registered
Joined
·
1,768 Posts
Don't feel lonesome or pregnant... I spent 15 minutes the other night figuring out the same problem.. ;) The clip on the Muth's is a BIT too tight to slide onto the mount correctly, and they weren't quite in the top..

You were right the mirrors were not installed at the top correctly. Once I read your post it was on easy fix and I love the mirrors.I want to thank everyone for their help. Nobody flamed me, everyone just tried to help and for that I say thanks!
 

·
Registered
Joined
·
2,731 Posts
You were right the mirrors were not installed at the top correctly. Once I read your post it was on easy fix and I love the mirrors.I want to thank everyone for their help. Nobody flamed me, everyone just tried to help and for that I say thanks!
:congrats:
Glad you got it the way it should be. Enjoy!
 
1 - 19 of 19 Posts
Top