GL1800Riders Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
About a month ago, my turn signals stopped working on my 2015 Wing. I was riding and when I hit the signals, nothing seemed to happen. Took the bike to the shop and it spent the next three weeks there all taken apart with the Mechanic and Honda on the phone trying to figure out what was wrong. Finally came down to replacing the turn signal cancellation switch and a relay, which was replaced with some kind of "LED Relay".

Rode the bike about 250 miles or so with no issue after that. Put it away for a week, then went out for a ride today and the signals stopped working again.

Went back to the shop (another 37 miles) and they didn't work the whole time, until the last turn I made to go into the shop parking lot. They continued to work while they were checking me in, and then started working on and off.

We noticed that if you tapped on the fairing just below and forward of the mirrors where the fairing kind of raps around the forks, the signals would begin to work. Tap there again and they would stop. After awhile of trying to figure that out, the signals just stopped blinking again.

My lighting set up is the following. I have the Electrical Connections LED bulbs in the high and low beams. I have LED turn signals in the rear and led tail lights. I have the Add-On Fog Lights, which look just like the SoCal daytime running light, foglight, turn signal combo.

I need the bike in a week for a trip up to Canada, so I'm getting pretty nervous. Any ideas would be really appreciated!!!
 

·
GL1800 Doctor
Joined
·
20,374 Posts
About a month ago, my turn signals stopped working on my 2015 Wing. I was riding and when I hit the signals, nothing seemed to happen. Took the bike to the shop and it spent the next three weeks there all taken apart with the Mechanic and Honda on the phone trying to figure out what was wrong. Finally came down to replacing the turn signal cancellation switch and a relay, which was replaced with some kind of "LED Relay".

Rode the bike about 250 miles or so with no issue after that. Put it away for a week, then went out for a ride today and the signals stopped working again.

Went back to the shop (another 37 miles) and they didn't work the whole time, until the last turn I made to go into the shop parking lot. They continued to work while they were checking me in, and then started working on and off.

We noticed that if you tapped on the fairing just below and forward of the mirrors where the fairing kind of raps around the forks, the signals would begin to work. Tap there again and they would stop. After awhile of trying to figure that out, the signals just stopped blinking again.

My lighting set up is the following. I have the Electrical Connections LED bulbs in the high and low beams. I have LED turn signals in the rear and led tail lights. I have the Add-On Fog Lights, which look just like the SoCal daytime running light, foglight, turn signal combo.

I need the bike in a week for a trip up to Canada, so I'm getting pretty nervous. Any ideas would be really appreciated!!!
Do the hazards work? If so, your issue is with the cancel unit or it’s wiring. If the hazards are dead, then it’s an issue with the flasher relay or it’s wiring. If you turn on the right signal, does the right side mirror pod go dark? Dealer mechanics suck at electrical issues and they really suck when it comes to the turn signal circuit on this bike. It doesn’t work like a car and that’s where their thinking goes astray.
 

·
IronMan
Joined
·
17,639 Posts
About a month ago, my turn signals stopped working on my 2015 Wing. I was riding and when I hit the signals, nothing seemed to happen. Took the bike to the shop and it spent the next three weeks there all taken apart with the Mechanic and Honda on the phone trying to figure out what was wrong. Finally came down to replacing the turn signal cancellation switch and a relay, which was replaced with some kind of "LED Relay".

Rode the bike about 250 miles or so with no issue after that. Put it away for a week, then went out for a ride today and the signals stopped working again.

Went back to the shop (another 37 miles) and they didn't work the whole time, until the last turn I made to go into the shop parking lot. They continued to work while they were checking me in, and then started working on and off.

We noticed that if you tapped on the fairing just below and forward of the mirrors where the fairing kind of raps around the forks, the signals would begin to work. Tap there again and they would stop. After awhile of trying to figure that out, the signals just stopped blinking again.

My lighting set up is the following. I have the Electrical Connections LED bulbs in the high and low beams. I have LED turn signals in the rear and led tail lights. I have the Add-On Fog Lights, which look just like the SoCal daytime running light, foglight, turn signal combo.

I need the bike in a week for a trip up to Canada, so I'm getting pretty nervous. Any ideas would be really appreciated!!!
JUST TAKE A REFRESH ON HAND SIGNALS :wink2:
 

·
Registered
Joined
·
39 Posts
Discussion Starter #5
Do the hazards work? If so, your issue is with the cancel unit or it’s wiring. If the hazards are dead, then it’s an issue with the flasher relay or it’s wiring. If you turn on the right signal, does the right side mirror pod go dark? Dealer mechanics suck at electrical issues and they really suck when it comes to the turn signal circuit on this bike. It doesn’t work like a car and that’s where their thinking goes astray.
Yes it does! Not looking at the bike because it's in the shop right now, but I distinctly remember standing in front of the bike as the shop mechanic turned on the left signal (my right side standing in front of the bike) and the mirror pod went out. I believe it did that for the other side as well. As far as the hazards go, I don't believe they were coming on either, but I can have them check that again
 

·
GL1800 Doctor
Joined
·
20,374 Posts
Yes it does! Not looking at the bike because it's in the shop right now, but I distinctly remember standing in front of the bike as the shop mechanic turned on the left signal (my right side standing in front of the bike) and the mirror pod went out. I believe it did that for the other side as well. As far as the hazards go, I don't believe they were coming on either, but I can have them check that again
Ok, since they changed your flasher to an electronic version, there may be an issue with its wires or socket. The only thing up front, other than the lights themselves, is the position light relay and it wouldn’t stop the signals from working.
 
1 - 6 of 6 Posts
Top