GL1800Riders Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2008 with on board Nav system during this hot summer I noticed the LCD screen had gray and dark black areas that look like paint splatters has any one dealt with this before and how do I fix it. If i need to replace the LCD screen
doe anyone know of a good source for part other than Honda Dealer. I was hoping that it would go away but its been 30 days and the screen has not refreshed its self.
 

·
Registered
Joined
·
1,177 Posts
Did you have the bike parked in direct sunlight on the screen. Remember the screen is made up of liquid crystal and the sun may have heated the crystals until one broke. In the winter, extreme cold can do the same thing to liquid displays. Can you using your finger push on the gray areas to see if it moves as you push. I can not remember if my GPS has a glass covering or not. If it does then using your finger will not work. Just thinking. Does the GPS seem to work except for the messed up area of the GPS screen?

Dan L
 

·
Registered
Joined
·
381 Posts
a picture would be cool.

I am looking into connecting into the screen and there is a probablity that there may be a "cheaper" non OEM display screen available.

Regards
Nigel
 

·
Registered
Joined
·
8,271 Posts
I have a 2008 with on board Nav system during this hot summer I noticed the LCD screen had gray and dark black areas that look like paint splatters has any one dealt with this before and how do I fix it. If i need to replace the LCD screen
doe anyone know of a good source for part other than Honda Dealer. I was hoping that it would go away but its been 30 days and the screen has not refreshed its self.
Sounds like what happens when you put on polarized sunglasses...
 

·
Registered
Joined
·
512 Posts
Should be a warranty problem haven't read about many problems with the navi screens. Maybe its covered will be pretty hard to replace with non OEM displays.:thumbup:
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Nav Display

The Nav System works fine . We pulled into hotel, our Room faced West so the bike had the evening setting sun on it.


 

·
Registered
Joined
·
2,685 Posts
Try disconnecting the battery, turn the key to run, and let it sit that way for 5 minutes. Turn the key off and reconnect the battery. Often a cold restart will cure all sorts of demonsion things controlled by a microprocessor.
 

·
Registered
Joined
·
24,624 Posts
That is a bad LCD display. It will have to be replaced. If you are still under warranty, go to the nearest dealer.

Those are not cheap.
 

·
Registered
Joined
·
205 Posts
I have exactly the same problem with my 2008 Nav display... bad pixels don't fix themselves, I wouldn't put a lot of hope in removing power for 9 minutes and doing a restart. It can't hurt but I would be surprised if it works... may try it myself.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #11
Thanks all

Hey thanks for all the input I will see if Honda covers this I did get Extended Warranty so hopefully it will be covered.

Thanks again
 
1 - 11 of 11 Posts
Top