GL1800Riders Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
107 Posts
Discussion Starter #1
01, 70,000 Miles


All brake lights work as they should using the foot pedal. When only using the front lever....nothing.


Just a little history....Over the last couple of years while chasing a cruise control issue I've replaced both lever bushings and installed a new right hand switch assembly. I've also had the brake recall done.


Micro switch?


All comments and suggestions appreciated.
 

·
Registered
Joined
·
2,278 Posts
Micro switch. Cheapest part to start with and most likely the problem. I wash my bike quite often and ride in the rain. The switches seem to last 2 to 4 years for me.
 

·
Registered
Joined
·
1,105 Posts
Switch would be easiest to check and it is good or bad, done. A little CRC contact cleaner may help, but also check that the wires haven't come unplugged from the switches... Left side switch wires were disconnected on my 02 when I bought it.

Sent from my Moto Z (2) using Tapatalk
 

·
Registered
Joined
·
2,691 Posts
They get sticky. even just working them for a few minutes, gets them to start working some. That tells you they could use some cleaning spray in there. The switch isn’t too expensive, if you want to replace it.
 

·
Registered
Joined
·
107 Posts
Discussion Starter #5
The micro switch is kinda where I thought I'd check next. Just wanting to see if others has had this exact issue and what they did to resolve it.
 

·
Registered
Joined
·
203 Posts
Here's the part # I think you might need: 35340-MCA-S41
I can't find this listed on the PARTZILLA diagram anymore, but, if you do a search for this part number, it'll show up as in stock.
 

·
IronMan
Joined
·
17,626 Posts
"listen " to switch should hear 2 clicks one is break and other ( i think) is for cruise set /release thing MINE THE LITE WORKED BUT COULDNT SET CRUISE
 
  • Like
Reactions: PastoT

·
GL1800 Doctor
Joined
·
20,370 Posts
This is the correct number for your 01, but it will probably be subbed to the newer number already mentioned above. #35340-MCA-000
 

·
Registered
Joined
·
107 Posts
Discussion Starter #10
This is the correct number for your 01, but it will probably be subbed to the newer number already mentioned above. #35340-MCA-000

Thanks techdude.... I was hoping the board expert on all things electrical with the wing would offer an opinion. You helped me with my FI / ECM issue last fall.
 
1 - 10 of 10 Posts
Top