GL1800Riders Forums banner
1 - 8 of 8 Posts
G

·
Discussion Starter · #1 ·
Well, I've got my All Balls installed, and am going back together. I noticed after installing the front fairing, that I have no turn signals. They light up, but do not flash, and the back ones don't light up at all. Any ideas. Position light sensor? Flasher(diode). I know I'm hooked up coming out of the top of the steering stem. I guess my biggest concern is why I have front but nothing on the rear.

I'll look deeper tomorrow, just wondered if someone had any other ideas.
 

·
Registered
Joined
·
626 Posts
Seeing that you just did streeing head bearings and after that is when the turn signals stopped work corectly. I would bet you did someting wrong with the cancel unit in the streeing head. The base of the unit can be out of oroentation, that's where I'd start looking if it is plugged in correctly.
 
G

·
Discussion Starter · #4 ·
Well, just to bring you all up to speed. Finally got it all put back together and working. Removed front fairing again and was going to start checking flasher/diode etc. During the process I bumped the position sensor connection, and had things working. Noticed upon disassembly that one of the pins gotten pulled back in the connector. Simple fix and glad I found it so easily.

Thanks for the suggestions
 
G

·
Discussion Starter · #7 ·
I agree now, after replacing these bearings, that it could be done without removing the front fairing. Good to know for the future.
 

·
Registered
Joined
·
7,618 Posts
You can do it without removing any fairings or even the wheel. I've seen it done, but I opted to remove the wheel and rebuild the forks at the time.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top