GL1800Riders Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
214 Posts
Discussion Starter #1
Good day folks, I have a question I would like an answer to If someone would be so kind. Every handlebar switch on my 06 nav/abs/airbag Wing is illuminated except the high/low beam switch and the reverse switch, Is this the norm or do I have a bad bulb?
Thanks,
Elk Man
 

·
Premium Member
Joined
·
12,497 Posts
Elk Man said:
Good day folks, I have a question I would like an answer to If someone would be so kind. Every handlebar switch on my 06 nav/abs/airbag Wing is illuminated except the high/low beam switch and the reverse switch, Is this the norm or do I have a bad bulb?
Thanks,
Elk Man
Unfortunetly, that's normal
:(

Dennis
 

·
Legend in His Own Mind
Joined
·
4,671 Posts
I don't know about normal, it's sure not practical. But thats the way the it is for some strange reason.
 

·
Registered
Joined
·
4,751 Posts
Elk Man[/quote] Unfortunetly, that's normal
:(

Dennis[/quote]

I would sure hate to think that i would have to look at those 2 switches to use them.
 

·
Premium Member
Joined
·
12,497 Posts
Teaser 1 said:
I don't know about normal
by "normal" I meant to imply his did not have burned out lights.

I guess I should have said "as Honda intended".

Dennis
 

·
Firm Member
Joined
·
3,159 Posts
The way I see mine is that all switches are lit if they can do it in the housing. The ones that have the lettering on the switch itself are not lit.
Horn, Start, Hi/Low beams.
 
1 - 10 of 10 Posts
Top