GL1800Riders Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
869 Posts
Discussion Starter #1
Does any one know what this code is? I also noticed my speedometer went to zero for an instant. THX
 

·
Registered
Joined
·
8,256 Posts
Here's the codes - 1 long and 1 short would be 11:



If the FI (PGM-FI or Programmed Fuel Injection) MIL (Malfunction Indicator Lamp) comes on pull over but DO NOT shut bike off. Put in neutral and put side stand down, RPM’s below 1500. This signals the ECM to send the error code to the FI light. Count the number of long and short flashes. This will give you the error code.

If you shut the bike off the error code is lost - sort of. It will be retained in the ECM but it is harder to get out. If the bike stops and the will not restart you can get the FI light to flash the error code by cranking the engine for 10 seconds. The FI light will then flash the error code.

Long Blink = 10 Short Blink = 1
i.e. long long long short short short = 33 check error code 33

Number of MIL blinks .Symptoms .Cause

0 No blinks • Engine does not start

• Open circuit in the power input and ground wires of the ECM: • Faulty bank angle sensor
• Open circuit in bank angle sensor related wires: • Faulty FI IGN relay: • Open circuit in FI IGN relay related wires
• Faulty engine stop switch: • Open circuit in engine stop switch related wires: • Faulty ECM: • Blown FI IGN fuse (20 A)
• Blown ST. KILL fuse (10 A):


0 No blinks • Engine operates normally
• Open circuit in MIL wire: • Faulty combination meter: • Faulty ECM


0 Stays lit • Engine operates normally
• Short circuit in service check connector wire: • Short circuit in MIL wire: • Faulty ECM


1 Blinks • Engine operates normally
• Loose or poorly connected MAP sensor connector: • Open or short circuit in MAP sensor wire: • Faulty MAP sensor


7 Blinks • Hard to start at a low temperature (ECM controls using preset value; coolant temperature: 85° C/185° F)
• Loose or poorly connected ECT sensor connector: • Open or short circuit in ECT sensor wire: • Faulty ECT sensor


8 Blinks • Poor engine response when operating the throttle quickly (ECM controls using preset value; throttle opening: 0° )
• Loose or poorly connected TP sensor connector: • Open or short circuit in TP sensor wire: • Faulty TP sensor


9 Blinks • Engine operates normally (ECM controls using preset value; intake air temperature: 28° C/82° F)
• Loose or poorly connected IAT sensor connector
• Open or short circuit in TP sensor wire: • Faulty IAT sensor


10 Blinks • Engine operates normally at low altitude
• Engine idles roughly at a high altitude (ECM controls using preset value; barometric pressure: 760 mm Hg/1,013 hPa)
• Loose or poorly connected BARO sensor connector: • Open or short circuit in BARO sensor wire: • Faulty BARO sensor


11 Blinks • Engine operates normally
• Loose or poorly connected vehicle speed sensor connector
• Open or short circuit in vehicle speed sensor wire: • Faulty vehicle speed sensor


12 Blinks • Engine does not start
• Loose or poorly connected No. 1 injector connector: • Open or short circuit in No. 1 injector wire: • Faulty No. 1 injector


13 Blinks • Engine does not start
• Loose or poorly connected No. 2 injector connector: • Open or short circuit in No. 2 injector wire: • Faulty No. 2 injector


14 No blinks • Engine does not start
• Loose or poorly connected No. 3 injector connector: • Open or short circuit in No. 3 injector wire: • Faulty No. 3 injector


15 Blinks • Engine does not start
• Loose or poorly connected No. 4 injector connector: • Open or short circuit in No. 4 injector wire: • Faulty No. 4 injector


16 Blinks • Engine does not start
• Loose or poorly connected No. 5 injector connector: • Open or short circuit in No. 5 injector wire: • Faulty No. 5 injector


17 Blinks • Engine does not start
• Loose or poorly connected No. 6 injector connector: • Open or short circuit in No. 6 injector wire: • Faulty No. 6 injector


18 Blinks • Engine does not start
• Loose or poorly connected camshaft position sensor connector
• Open or short circuit in camshaft position sensor wire: • Faulty camshaft position sensor


19 Blinks • Engine does not start
• Loose or poorly connected ignition pulse generator connector:
• Open or short circuit in ignition pulse generator wire: • Faulty ignition pulse generator


21 Blinks • Engine operates normally
• Open or short circuit in right O2 sensor wire: • Faulty right O2 sensor


22 Blinks • Engine operates normally
• Open or short circuit in left O2 sensor wire: • Faulty left O2 sensor


23 Blinks • Engine operates normally
• Open or short circuit in right O2 sensor heater wire: • Faulty right O2 sensor


24 Blinks • Engine operates normally
• Open or short circuit in left O2 sensor heater wire: • Faulty left O2 sensor


25 Blinks • Engine operates normally
• Loose or poorly connected right knock sensor connector: • Open or short circuit in right knock sensor wire: • Faulty right knock sensor


26 Blinks • Engine operates normally
• Loose or poorly connected left knock sensor connector: • Open or short circuit in left knock sensor wire: • Faulty left knock sensor


29 Blinks • Engine stalls, hard to start, rough idling
• Loose or poorly connected idle air control (IAC) valve connector: • Open or short circuit in IAC valve wire: • Faulty idle air control valve


33 Blinks • ECM does not hold the self diagnostic data
• Faulty E2-PROM in ECM • Engine operates normally


41 No blinks • Engine operates normally
• Loose or poorly connected connector in gear position switch related circuits
• Open or short circuit in gear position switch wires: • Faulty gear position switch: • Faulty clutch switch: • Faulty side stand switch
 

·
Registered
Joined
·
7,613 Posts
Here's the codes - 1 long and 1 short would be 11:
11 Blinks • Engine operates normally
• Loose or poorly connected vehicle speed sensor connector
• Open or short circuit in vehicle speed sensor wire: • Faulty vehicle speed sensor
Looks like you need to spend $100. It will just keep on getting worse. Causes the signals not to cancel, cruise cancelling unpredictably, poor performance and other things. It does cost you extra gas when it bottoms out.
 

·
Registered
Joined
·
869 Posts
Discussion Starter #4
thank youi

i will be saving this info.
 

·
GL1800 Doctor
Joined
·
20,207 Posts
Here is it's location on the right side of the engine block, there's a chance it's just corrosion in the connector for it.

 

·
Registered
Joined
·
365 Posts
I had the exact sme issue, ai took my 02 to Everett Power Sports and had a new speed sensor installed for $100. Solved the problem...
 

·
Registered
Joined
·
869 Posts
Discussion Starter #7
you guys rock. looks like i can get to it just by taking some plastic off to check the connector first.
 

·
Registered
Joined
·
869 Posts
Discussion Starter #8
i didnt see the part number on the direct parts site
 
1 - 10 of 10 Posts
Top