GL1800Riders Forums banner
  • Hey everyone! Enter your ride HERE to be a part of MAY's Ride of the Month Challenge!

1 - 7 of 7 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter · #1 ·
:?::?:Cruising along at 70 mph on freeway when FI light comes on and stays on..Engine continued to run with no problems..Exited at next ramp. Pulled over, stopped and shut down completely. Turned ignition key back to on..FI light came on and went out as part of start sequence.
Continued the ride without incident. All other engine indications were normal. It's a 2008 w/ABS and 52,000 miles so far.

Question: Was it a random incident and off/on with the starter switch did a reset? The MOM says to take it in to the dealer. I'd prefer not to and would rather try to fix it myself(if it needs fixing, that is). :shrug:

TIA..
 

·
Vendor
Joined
·
18,687 Posts
Not random ... it means that there is a problem.

Next time, pull over, leave running, put in nuetral, and put kick stand down. The light will then flash long and short. A long = 10 and a short = 1.

Ex. long, long, short, short, short = 23. Got that?

Wait for it to do it again, pull over, kickstand down, count the flashes and come back in here and tell us what the count is.
 

·
Registered
Joined
·
1,874 Posts
If the flash count is 12 to 17 (one long, two-to-seven shorts) DO NOT turn the bike off unless you are somewhere you don't mind being for a while.

Those are the fault codes for failed fuel injectors. If you turn the engine off it will not restart.
 

·
Vendor
Joined
·
18,687 Posts
If the flash count is 12 to 17 (one long, two-to-seven shorts) DO NOT turn the bike off unless you are somewhere you don't mind being for a while.

Those are the fault codes for failed fuel injectors. If you turn the engine off it will not restart.
:thumbup: ... that's a good suggestion :)
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #5 ·
Been busy.. Just got back to the board..

Thanks for responses..

I've been riding without problems since the initial incident..

I'll do the "count the flashes" next time if it happens again without shutting down..

Engine has been running great since then..

:shock::-?
 

·
Registered
Joined
·
103 Posts
Re

This is great info , I don't have a problem but if I do a least now I know
 

·
Registered
Joined
·
1,200 Posts
Different circumstances, but a similar thing happened to me a few weeks back. Very hot day pulling trailer through the mountains 2 up. Noticed the FI light was on. Running OK but seemed a tad sluggish. Stopped for a break when I got over the mountain. Little harder to check codes on a trike, so was hoping it would get the rest of the way home and I would check the code then. Started up fine, running smoothed out and has not done it again. It's an '05 that I bought about a year ago with only about 6,000 miles, so it hadn't been ridden much. Had about 25,000 on it when this happened.
 
1 - 7 of 7 Posts
Top