GL1800Riders Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Help! Today the right signal lights on my 2003 Wing are flashing double time. Front and back both appear to be working. Any ideas would be appreciated . Thanks. Allan
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
re: faulty signal

No Quickdraw , a bulb doesn't appear to be burnt out. The left signals flash normally but the right flash twice as fast on the front and back , just as if a bulb is burnt out. Living up here in Canada I have a hard time explaining . Didn't want to take it to the shop if it was something I could try and fix myself. Thanks eh! Allan
 

·
Registered
Joined
·
4,563 Posts
I'm clueless, but did you just wash the bike? I've had strange electrical things happen after giving the bike a bath. This weekend the push to cancel on my signals didn't work for about 50 miles, I assume until things dried out.
 

·
Registered
Joined
·
1,244 Posts
You don't say if you have removed the bulbs and inspected them. Sometimes a defective bulb looks perfectly fine. It could be that one of the filaments has burned out in the middle and one end has fallen down making contact with the other filament. This would result in a reduced resistance in that side of the circuit and a faster flash cycle.
I would try replacing the bulbs one at a time and see if the trouble clears.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
re: faulty signal

Update: Yes I checked the bulb by switching it with the left side and found it works. I removed the back covering where the trailer wiring is( which I had installed at a shop ) and found that a blue connecter with two green wires, was disconnected. Once I plugged it in everything was fine. With it unplugged the red light just below the signal light would flash. Maybe this is some kind of safety feature. Anyways thanks for the input. Allan
 
1 - 6 of 6 Posts
Top