GL1800Riders Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4,424 Posts
Discussion Starter #1
I have a 2009 Goldwing and just replaced the right saddlebag. When I put the screws back in the latch mechanism, the door will no longer latch. If I put the latch cover in place but don’t put the screws in, the latch works fine. Is there some magic to get the latch to work once I put the screws back in?
 

·
Registered
Joined
·
5,907 Posts
I have a 2009 Goldwing and just replaced the right saddlebag. When I put the screws back in the latch mechanism, the door will no longer latch. If I put the latch cover in place but don’t put the screws in, the latch works fine. Is there some magic to get the latch to work once I put the screws back in?
I would try to put the screws in loose . Then try to operate latch. If it works tighten screws . If not adjust it with your finger to another spot and try again . Something is just off a bit. I replaced both bags and center piece on my o9 and installed 13 bags. It's been several years but it was not hard and your lock issue had to be a small adjustment as stated and make sure your cable is routed correctly and all smooth no sharp turns. Good luck .
 

·
Registered
Joined
·
4,424 Posts
Discussion Starter #3
Latch

I would try to put the screws in loose . Tet to operate latch. If it works tighten screws . If not adjust it with your finger to another spot and try again . Something is just off a bit. I replaced both bags and center piece on my o9 and installed 13 bags. It's been several years but it was not hard and your lock issue had to be a small adjustment as stated and make sure your cable is routed correctly and all smooth no sharp turns. Good luck .
With screws only in the outward facing holes, it works OK. Late last night I found that it started failing when I got the rear part of the plastic latch cover all the way up inside the bag. I ran out of time before I tried this, but I'm going to wire tie the cables up out of the way in the back to see if that helps. I am sure it is something I'm doing fundamentally wrong because I had the same problem with the bags on my old bike when I replaced the bag.
 
1 - 3 of 3 Posts
Top