GL1800Riders Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I am new to riding a GL1800. When riding with my feet on the highway pegs I feel a significant amount of heat coming from the right side of the engine but not the left side. My temperature guage remains in the normal range, however. Can anyone offer a reason/suggestion for this experience?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
I am new to riding a GL1800. When riding with my feet on the highway pegs I feel a significant amount of heat coming from the right side of the engine but not the left side. My temperature guage remains in the normal range, however. Can anyone offer a reason/suggestion for this experience?
After further investigation I believe the heat is from the right side exhaust manifold and not the radiator. Is this normal?
 

·
Registered
Joined
·
70 Posts
I wish I could answer that for you. I have highway rests but never use them. Its possible that one side would be warmer than the other because of how things are offset with the motor.. I'm sure some of the crew here will chime in soon enough.

Bill
 

·
Registered
Joined
·
166 Posts
Interesting because I find that my left foot gets hotter than the right when using the highway pegs.

We'll just have to wait and see what everyone says.
 

·
Banned
Joined
·
7,603 Posts
Check for "openings" between those aftermarket chrome pieces your bike pic shows, I think.
Make sure the right ones are mounted the same as the left ones w/no gaps that would let heat "blow" out on your right foot.
 

·
Registered
Joined
·
221 Posts
That's normal on my bike too but more so when it's windy out. I just take my right foot off the highway peg for awhile when it gets too hot to cool off. What you wear near that area will also make a difference.
Good Luck
 

·
Registered
Joined
·
335 Posts
:coffee1:
 

·
Vendor
Joined
·
17,832 Posts
I am new to riding a GL1800. When riding with my feet on the highway pegs I feel a significant amount of heat coming from the right side of the engine but not the left side. My temperature guage remains in the normal range, however. Can anyone offer a reason/suggestion for this experience?
Are youu missing a spoiler on one side?
 
1 - 10 of 10 Posts
Top