GL1800Riders Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
4,424 Posts
Discussion Starter #1
I just noticed this issues this morning and I have no idea how long it has been going on. When I first start the bike, the right front running light does not come on. As soon as I activate either blinker it does come on and it stays on. Any ideas what would cause that?
 

·
Registered
Joined
·
972 Posts
Possibly a broken filament in bulb or a bad contact. Heat from the other filament allows contact. A new bulb may be in order.



You do understand that this is Holiday Inn Express guessing? LOL
 

·
GL1800 Doctor
Joined
·
20,372 Posts
I just noticed this issues this morning and I have no idea how long it has been going on. When I first start the bike, the right front running light does not come on. As soon as I activate either blinker it does come on and it stays on. Any ideas what would cause that?
The right side position light gets power from part of the turn signal switch and the position light relay under the seat on your model year. When you turn on the right turn signal, the switch removes power from the right side, turning it off, so the flashing turn filament is more noticeable. This makes the right one go off and the left one stays on while you are turning. Once the turn is complete or you manually cancel the signals, the cancel unit removes the ground that activated the flasher relay and also removes the same ground from the position light relay. This allows the relay to de-energize, routing the switch power that is keeping the left light on to go through the normally closed contacts of the relay and back to the right side light. This turns it on as the flashing filament stops flashing. If you use the left turn signal everything occurs the same except all of the right side and left side is reversed. So, when you first turn on the bike and the left side is on, but the right side is not, this indicates the last turn made was on the right side and the position light relay is failing to send the power to the right side. Once you use the signals, you are “exercising” the relay and probably knocking off oxidation on its contacts. Check the bulb connection in its socket first, then I would swap or replace the relay with a new 5 pin relay. If this doesn’t fix it, then it’s a bad connection in the wiring.
 

·
Registered
Joined
·
4,424 Posts
Discussion Starter #5
Troubleshooting

Thank you for the suggestions. It sounds like time for a little troubleshooting. Interestingly, if I shut off the bike with the left blinker active, the right position light comes on immediately when I turn the key on again.
 

·
Registered
Joined
·
495 Posts
Thank you for the suggestions. It sounds like time for a little troubleshooting. Interestingly, if I shut off the bike with the left blinker active, the right position light comes on immediately when I turn the key on again.
From what techdude said, I think that could be expected.

With the left blinker on, the right position light would be on and its relay would be off, and its contacts are good. Turning off the bike and back on, the contacts would still be good. (I think)

Engaging the relay and opening its contacts is a setup for a bad connection the next time the relay is turned off.

I would swap the relay.
 

·
GL1800 Doctor
Joined
·
20,372 Posts
That’s because the right side will be powering straight from the switch. Think of it this way, when you use the turn signal switch, the part that powers the position light is wired the opposite from the turn signal. Right turn signal powers the left position light and Left turn signal powers the right position light. From your symptom, it sounds like the position light relay is the culprit.
 

·
Registered
Joined
·
1,231 Posts
After I had the same experience and same questions awhile back with the same explanations. I changed relays, still same, cleaned all my signal lite connections (way to many accessories hooked to them) (plug & play type). Then I furmembered that I always use my turn signal to turn into my 25ft drive way. So being a Fla driver who are famous for NOT using a turn signal. I quit using them to turn into my drive way and now when I start my Wing in my garage both running lights are always on. Works for me!!! YMMV
 

·
Registered
Joined
·
3,103 Posts
The relay fixed mine. Easy to just swap in a relay from another function to see if the problem goes away. I swapped in the headight height adjust relay. I don't care to ever adjust my headlight, so never bothered to replace the relay to that position.
 

·
Registered
Joined
·
1,318 Posts
The relay fixed mine. Easy to just swap in a relay from another function to see if the problem goes away. I swapped in the headight height adjust relay. I don't care to ever adjust my headlight, so never bothered to replace the relay to that position.

What? You didn't replace your on-board spare?!? :surprise: :wink2:
 

·
Registered
Joined
·
2,162 Posts
I had the same problem with my 09. I replaced the bulb, swapped relays, checked some connections and nothing helped. Finally I removed the position contact from the left bulb so now neither light is on. Not a repair but at least I'm not riding around with one on and one off.
 

·
Registered
Joined
·
2,347 Posts
I had a similar issue with my left position/turn signal lamp.
I believe I had a switch issue.
First, I cleaned the heck out of the switch with contact cleaner.
That seemed to help for a while.
Then I thought more about the switch.
I used to cancel the turn signals by pushing in on the button.
I then started to cancel the turn signals by sliding the button back to the centre position to cancel them.
After "exercising" the switch this old fashioned way, the problem seems to have disappeared.
Worth a shot to try?
 

·
GL1800 Doctor
Joined
·
20,372 Posts
I had the same problem with my 09. I replaced the bulb, swapped relays, checked some connections and nothing helped. Finally I removed the position contact from the left bulb so now neither light is on. Not a repair but at least I'm not riding around with one on and one off.
So, your right one never comes on now? Even during a left turn?
 
1 - 19 of 19 Posts
Top