GL1800Riders Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
197 Posts
Discussion Starter #1
I returned from a trip from the Black Hills this weekend, and the bike ran fine the whole time. Rode in a little rain while there. On monday I had to take it on some business and rode about 100 miles in a light rain, On the way back home, it stopped raining, and I filled with gas at a convenience store about 30 miles from home. They pump a lot of gas. It ran fine the rest of the way home. I didn't ride on Tuesday. Wednesday night I went for a ride and the bike ran rough. It idled OK, but lacked power and the exhaust noise seemed louder than normal. It almost seemed like I got a bad tank of gas. Any suggestions?
 

·
Registered
Joined
·
24,624 Posts
I returned from a trip from the Black Hills this weekend, and the bike ran fine the whole time. Rode in a little rain while there. On monday I had to take it on some business and rode about 100 miles in a light rain, On the way back home, it stopped raining, and I filled with gas at a convenience store about 30 miles from home. They pump a lot of gas. It ran fine the rest of the way home. I didn't ride on Tuesday. Wednesday night I went for a ride and the bike ran rough. It idled OK, but lacked power and the exhaust noise seemed louder than normal. It almost seemed like I got a bad tank of gas. Any suggestions?
Dump a bottle of Techron in there. Go from there.
 

·
Registered
Joined
·
7,613 Posts
Bad gas is my guess. It just took a little time for the bad stuff to settle to the bottom. Were they filling the underground tanks? I always never buy gas when they are doing that.
 
1 - 3 of 3 Posts
Top