GL1800Riders Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
HAS ANYONE HAD PROBLEMS WITH THE HORN ON 2003 GL1800 HORNS WERE GREAT BUT WANTED LOUDER INSTALLED WING BLASTERS WERE SOME WHAT LOUDER. THEN THEY GOT SICK NOTHING SEEMED TO HELP. SO I REINSTALLED THE STOCK HORN BACK ON THE BIKE. STILL SOUNDS SICK. WHILE BIKE WAS IN THE SHOP FOR ECM AND CAMPIAN THEY INSTALLED A NEW HORN AND WAS STILL SICK SO THEY ADJUSTED IT THE SOUND IS MUCH DIFFRENT BUT STILL HAS PROBLEMS DOSE NOT SOUND LIKE A WING HAS ANYONE HAD THIS PROBLEM AND FOUND A FIX TS1800 :(
 

·
Registered
Joined
·
106 Posts
Not sure if this will help or not.

Had a simlar problem on my V65. The problem was not the horm but the wires attached to the horn and a dirty switch. I think (don't have the manual here) that you may be able to disconnect the wires from the switch, short them together and see if that helps. Also check the contacts where the wires attach to the horn. Careful inspection may reveal broken wires near the lugs in the wires or corroded connections.

Jay
 

·
Registered
Joined
·
10 Posts
Sick Horns

The horn on my '02 GL-1800 sounded different than a buddy of mine's and he had the same year bike. I ordered a set of Wing Blasters and after removing the lower cowel to install them, found that one of the wires had come off of one of the OEM horns. Oh well, I went ahead and replaced them with the Wing Blasters and let me tell you, they are LOUD!!! :shock:
 

·
Registered
Joined
·
18 Posts
Discussion Starter #6
i have checked for proper voltage and ground with meter all checks ok i have thought about the horn switch but have not physically looked at the contacts.guess i should have done that when i was installing the revco's .i also switched the horn relay with an acc. relay and did not help. that was when i thought honda should take look at it.thanks for the input will let every one know what it takes to fix the problem TS1800
 

·
Registered
Joined
·
143 Posts
I liked the horn's on my 03 GL1800 so much I thought I would just put a set on my 01 Valk I/S. Ordered a set from Hal and installed same to discover that one was BAD ,NO HOOT. Returned to Hal and he sent new horn. New horn worked fine. Some NEW Horns Do Not WORK.
Just my 2 cents.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #8
TOOK THE HORN SWITCH :idea: DOWN THIS WEEKEND EVERY THING IS FINE I THINK THE NEXT THING WILL BE TO COMPARE TO ANOTHER WING FOR VOLTAGE AND ECT. THEN BACK TO MOTHER HONDA.
 

·
Registered
Joined
·
348 Posts
You may have the problme of not enought Amperage.

The ability for power to do work. It appears if the device has a relay it draws a moderate amount of power.

Amperage releates to the size of the pipe going to the shower head. If you have Volts but ony a 1/4 pipe going to the show head you will not be a happy camper.

So where is the dirty connection, loose wire, or crimped wire.

Try taking power directly to the horn from another power source. Is the horn now working properly.
 

·
Registered
Joined
·
300 Posts
sick horns

you can eliminate all of the wiring by removing the horns and using jumper cables from a different batery or powersource to each horn individually to see if they are both fine if they sound wrong and you will be able to hear it for sure ..you can try tuning them with the screw that is sometimes on the back of them by lossining the lock nut and turning the screw a very small amount at a time ..sometimes that is all that is needed. if they both sound fine the first time then your wiring is the culpret.. good luck .....jake
 

·
Registered
Joined
·
18 Posts
Discussion Starter #11
HI GUYS I DECIDED TO INSTALL THE LOWER DRIVING LIGHTS ON MY GL1800 THIS WEEKEND WHILE I WAS THAT CLOSE TO THE HORNS I REINSTALLED THE NEW WING BLASTERS THAT HAL HAD SENT ME THEY SEEM TO WORK GREAT. STRANGE FOR A HORN TO GO BAD WHILE SETTING IN THE BOX ON A SHELF. THE REASON FOR THE HORN STILL SOUNDING SICK WHEN IT CAME BACK FROM THE SHOP WAS BECAUSE THEY INSTALLED A SECOND LOW NOTE HORN ,THEN TRYED TO ADJUST IT TO CORRECT THE PROBLEM.WHY THE 1ST SET OF WINGBLASTERS WENT BAD IAM NOT SURE THANKS FOR THE INPUT AND KEEP THE RUBBER SIDE DOWN.
 
1 - 11 of 11 Posts
Top